Agisoft Metashape User Manual

Standard Edition, Version 2.2



Agisoft Metashape User Manual: Standard Edition, Version 2.2

Publication date 2025
Copyright © 2025 Agisoft LLC




Table of Contents

OVEIVIBIV .ttt ettt e et h e et e e et e b e et e e b e e et eb e e e e a e e e e s \Y
HOW BT WOTKS ettt et ettt e e et e e aa e e e enans %
ADOUL the MANUAL ......eeee e e et e et e e et e e e et e eeens %

1. Installation @and ACHVELION .......c.uuuiiiiiii ettt e e e e e 1
SYSLEM TEQUITEIMENTS ... eeeett ettt ettt ettt ettt ettt et e et e e e e et e e e e et e e e e ete e eeenbaaaeaees 1
GPU reCOMMENTALIONS ... ..iieiti ettt ettt et e e et e e eeeanas 1
INSEAIALION PrOCEAUIE ......ceeeii ettt et e et e et e e e e 2
30-day trial and demO MOOE ..........uuiiiii et 3
ACHVALTON PrOCEOUIE ... ettt ettt e e et e e e et e e e et e e e entaeeeees 3

2. CAPLUNNG SCENMAITOS ....vueeeeti ettt ettt ettt e et e et et e et et e e et et e e et ab e e et et e e e e ana s 5
EQUIDIMENT .ottt 5
ObjECL/SCENE TEAUINEIMENTS ... eeeett ettt e e e ettt e ettt e ettt e ettt e ettt e e et et e e e eebe e eeeereaeeenn 5
CAPLUINTNG SCENAIIOS ... eevt ettt ettt ettt ettt ettt e e et e et e e e et et e e e et e e e era s 6
[MBGE PrEPIOCESSING ... eeeteneeeett ettt ettt et e et e e e et e e e et e et e et e et e et e et ene e e e enna e eeenenns 8
RESIICHIONS ... ettt ettt ettt et e et e e e s 8
LenS CalIDIELION ........iiiiii e 8
Excessive image elimination ...........coouiiiiiiiii e 10

3. .GENErAl WOPKFIOW ...t e s 12
PreferenCeS SEIIINGS ... .cieeri ettt e 12
LOBAING SOUMCE TBEA ...t eeeeit ettt ettt e e et e e e e e eaan s 14
ALIGNING PROLOS ...t e et e et e e et e e et e e ent e eee 18
BUIldiNg POINE ClOUT .....coutniiiii e e et e e e et e eeees 22
BUITAING MOTEL ... .ot ettt e e e e e e e e e e eees 25
BUIldiNg MOTE! TEXTUIE ......uneeeiit ettt e e e e e e eees 29
BUIIAING PANOTAIMA .....ceetiieiei ettt e e e 34
Saving iNErMEIate rESUITS ........u. ittt et e e e e eeees 36
EXPOITING FESUITS ...ttt ettt ettt ettt e e e e et e eeeete e eeenes 37
Cameratrack creation and fly through video rendering ...........ccceuiviieiiiiniiiiiiieie e, 45
SLEFEOSCOPIC MOUE ...ttt ettt e e e et e e e rb e e e eba s 46

4. Improving camera alignMENt TESUITS .........iiiieeieiiii e 48
CameEra CAlTDIAION ... .oieeei ettt e e et e e eee 48
1©] 0111 411 (o o E PSP PP UPPPTTR 52

B BITING et et 54
USING IMBSKS .ttt sttt ettt e ettt e ettt e ettt s e et ettt e e e e bt e e e eebb e eeeenaaeeees 54
Editing POINT ClOUT ........iiiiie et 63
Editing MOdel GEOMELIY ..ot 68
SEAMINES EUITING ...vveeeeeit e e ettt e et e e et e e e e et e eeenes 73

B. AULOMEBLION ...ttt ettt e et et e et e e e et et n e e e et e e e na s 75
USING CNUNKS ...ttt e e et e et e e e e e ennans 75

A. Graphical USEr INTEITACE .. .ot e e e et e et 82
APPHICALTON WINTOW ...ttt e et e e ettt e e e et e e eene e eeees 82
IMENU COMMIANGS ...ttt ettt e et e et et e e e et e e e e aba s 86
TOOIEN DULLONS ...t 93
HOE K Y S ettt et 96

B. SUPPOIEd FOMMELS ...ttt ettt et e e e e e e enaas 98
T4 0= PP 98
CameEra CAlTDIATION ......oieeei ettt ettt e e eee 98
Interior and exterior camera orientation PAraMELErS ..........ccuuueieeriieeeei e 99
THE POINES ..ttt 99
Tie point cloud / POINE ClOUT ...........iiiiie e 99
MESH MOEL ... et 100




Agisoft Metashape User Manual

L= L= 7= 0L 100
YT L= o TP 101
C. MEashape PrEfEIENCES ... civi it ee ettt e e e e e et e e e e e e et e e et eeaneees 102
€T o 1c = = | o PRSPPI 102
L€ U = | o PP 104
Appearance tab (MOAEl VIEW) ....coieiii e e e 105
Appearance tab (Ortho VIEW) ....ooue i e e e e 108
Appearance tab (PROtO VIEW) ....ooueii e e e e e e 109
[N E= Y7o (o g I - o 111
AGVANCEA 10 .o 113
D 0= 10T = T 410 L= £ S SPPPTPPN 115
FFaME CABIMEIES .....ieiiieei ettt e et e e e e e e e e e e en e e e enees 116
FISNEYE CAMEIAS .....iiiiiii e e e e e e e et e eeaaees 116




Overview

Agisoft Metashape is a stand-al one software product that performs photogrammetric processing of digital
images (aerial and close-range photography) and generates 3D spatial datato be used in GIS applications,
cultural heritage documentation, and visual effects production as well as for indirect measurements of
objects of various scales.

The software allows to process images from RGB, thermal into the spatial information in the form of
point clouds, textured polygonal models. Wisely implemented digital photogrammetry technique enforced
with computer vision methods results in smart automated processing system that, on the one hand, can be
managed by a new-comer in the field of photogrammetry, yet, on the other hand, has a lot to offer to a
specialist who can benefit from advanced features like stereoscopic mode and have complete control over
the results accuracy, with detailed report being generated at the end of processing.

How it works

Typical tasks for a photogrammetry processing project in Metashape isto build atextured 3D model. Data
processing procedure with Agisoft Metashape consists of two main steps.

1. The first step is called alignment. It includes aeria triangulation (AT) and bundle block adjustment
(BBA). At this stage Metashape searches for feature points on the images and matches them across
images into tie points. The program aso finds the position of the camera for each image and
refines camera calibration parameters (estimates interior (10) and exterior (EO) camera orientation
parameters).

The results of these procedures are visualized in the form of atie point cloud and a set of camera
positions. The tie point cloud represents the results of image alignment and will not be directly used
in further processing (except for the tie point cloud based surface reconstruction method, which is
suitable only for quick estimates, e.g., of completeness of adata set). But thetie point cloud is necessary
for the determination of depth maps (based on the common tie points camera pairs for the depth
maps calculation are selected). However it can be exported for further usage in external programs. For
instance, atie point cloud model can be used in a 3D editor as a reference. On the contrary, the set of
camera positionsis required for further 3D surface reconstruction by Metashape.

2. The second step is generation of a surfacein 3D (mesh) . Polygona model (mesh) can be textured for
photorealistic digital representation of the object/scene and exported in numerous formats compatible
with post-processing software, both for CAD and 3D-modeling workflows.

Photogrammetric point cloud can be built by Metashape based on the estimated camera positions and
images themselves (dense matching). Generated photogrammetric point cloud can be merged with
LiDAR data.

About the manual

Basically, the sequence of actions described above covers most of the data processing needs. All these
operations are carried out automatically according to the parameters set by user. Instructions on how to
get through these operations and descriptions of the parameters controlling each step are given in the
corresponding sections of the Chapter 3, General workflow chapter of the manual.

In some cases, however, additional actions may be required to get the desired results. Picturestaken using
uncommon lenses such as fisheye one may require preliminary calibration of optical system parameters
or usage of different calibration model specially implemented for ultra-wide angle lens. Metashape
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enables to reestimate extrinsic and intrinsic camera parameters, optimizing them for a tie point pool
preliminary filtered by user. Chapter 4, Improving camera alignment results covers that part of the
software functionality. In some capturing scenarios masking of certain regions of the photos may be
required to exclude them from the calculations. Application of masks in Metashape processing workflow
as well as editing options available are described in Chapter 5, Editing. Chapter 6, Automation describes
opportunities to save up on manual intervention to the processing workflow.

It can take up quite along time to reconstruct a 3D model. Metashape allows to export obtained results
and save intermediate datain aform of project filesat any stage of the process. If you are not familiar with
the concept of projects, its brief description is given at the end of the Chapter 3, General workflow.

In the manual you can also find instructions on the Metashape installation and activation procedures and
basic rules for taking "good" photographs, i.e. pictures that provide most necessary information for 3D
reconstruction. For theinformation refer to Chapter 1, I nstallation and Activation and Chapter 2, Capturing
scenarios.

Vi



Chapter 1. Installation and Activation

System requirements

Minimal configuration

» Windows 7 SP 1 or later (64 bit), Windows Server 2008 R2 or later (64 bit), macOS High Sierra or
|ater, Debian/Ubuntu with GLIBC 2.19+ (64 bit)

¢ Intel Core 2 Duo processor or equivalent

+ 8GB of RAM

Recommended configuration

e Windows 7 SP 1 or later (64 hit), Windows Server 2008 R2 or later (64 hit), macOS Mojave or later,
Debian/Ubuntu with GLIBC 2.19+ (64 hit)

* Intel Corei7 or AMD Ryzen 7 processor
» Discrete NVIDIA or AMD GPU (4+ GB VRAM)
» 32GB of RAM

The number of photos that can be processed by Metashape depends on the available RAM and
reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPix, 4 GB
RAM is sufficient to make a model based on 30 to 50 photos. 16 GB RAM will alow to process up to
300-500 photographs.

GPU recommendations

M etashape supports accelerated image matching; depth maps reconstruction; depth maps based model
model generation; texture blending; photoconsistent mesh refinement operation due to the graphics
hardware (GPU) exploiting.

NVIDIA
GeForce GTX 7xx series and later, Quadro M4000 and later with CUDA support.

AMD
Radeon R9 series and | ater, Radeon Pro WX 7100 and later with OpenCL 1.2 support.

Metashape is likely to be able to utilize processing power of any CUDA enabled device with compute
capability 3.0 and higher or OpenCL 1.2 and higher enabled device with SPIR support for stages specified
above, provided that CUDA/OpenCL drivers for the device are properly installed. However, because of
the large number of various combinations of video chips, driver versions and operating systems, Agisoft
is unable to test and guarantee M etashape's compatibility with every device and on every platform.

The processing performance of the GPU device is mainly related to the number of CUDA cores for
NVIDIA video chipsand the number of shader processor unitsfor AMD and Intel video chips. Additionally
depth maps based model model reconstruction aswell as photoconsi stent mesh refinement operations and
texture blending would benefit from larger amount of VRAM available.

Thetable below lists currently supported devices (on Windows platform only). Agisoft will pay particular
attention to possible problems with Metashape running on these devices.
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Table 1.1. Supported Desktop GPUs on Windows platform

NVIDIA AMD

GeForce RTX 4080 Radeon RX 7800 XT
GeForce RTX 3080 Radeon RX 6800
GeForce RTX 2080 Ti Radeon VI
TedaVV100 Radeon RX 5700 XT
TedaM60 Radeon RX Vega 64
Quadro P6000 Radeon RX Vega 56
Quadro M6000 Radeon Pro WX 7100
GeForce TITAN X Radeon RX 580
GeForce GTX 1080 Ti FirePro W9100
GeForce GTX TITAN X Radeon R9 390x
GeForce GTX 980 Ti Radeon R9 290x

GeForce GTX TITAN
GeForce GTX 780 Ti

M etashape supports texture blending on GPU using V ulkan technology on Linux and Windows OS. GPU
accelerated texture blending is currently supported for frame and fisheye type cameras on NVIDIA cards
since GeForce GTX 8XX / Quadro M4000 and driver versions from 435.xx and on AMD cards since
Radeon R9 29x series / FirePro W9100 and 17.1.x drivers. Some older GPUs and older driver versions
could also support texture blending using VVulkan, however, it is hot guaranteed.

Although Metashape is supposed to be able to utilize other compatible GPU models and being run under

all supported operating systems, Agisoft does not guaranteethat it will work correctly. However, all GPU-
based processing issues should be reported to Agisoft support team for more detailed investigation.

£ Note

« Use CPU enable flag to allow calculations both on CPU and GPU for GPU-supported tasks.
However if at least one powerful discrete GPU is used it is recommended to disable CPU flag
for stable and rapid processing.

» Using GPU acceleration with mobile or integrated graphics video chips is not recommended
because of the low performance of such GPUs.

* CUDA supported devices for some older macOS versions may require to install CUDA drivers
from official web-site first: http://www.nvidia.com/object/mac-driver-archive.html.

Due to lack of CUDA support on certain macOS versions Metashape will automatically switch
to OpenCL implementation for GPU-based processing on NVIDIA graphic devices.

Installation procedure

Installing Metashape on Microsoft Windows

To install Metashape on Microsoft Windows simply run the downloaded msi file and follow the
instructions.
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Installation and Activation

Installing Metashape on macOS

Open the downloaded dmg image and drag M etashape application bundle to the desired location on your
hard drive (for example, to Applications folder. Do not run Metashape directly from the dmg image to
avoid issues on license activation step.

Installing Metashape on Debian/Ubuntu

Unpack the downl oaded archive with aprogram distribution kit to the desired location on your hard drive.
Also, install the package: sudo apt install libxch-xinerama0. Start Metashape by running metashape.sh
script from the program folder.

30-day trial and demo mode

Once Metashape is downloaded and installed on your computer you can run it either in the Demo mode or
in the full function mode. On every start until alicense key sequenceis entered it will show on activation
diaog offering three options: (1) activate Metashape using a valid license code, (2) start a free 30-day
trial, (3) continue using Metashape in Demo mode. Starting a 30-day trial period allows to evaluate the
functionality of the program and explore the software in full-function mode, including save and export
features. Trial license is intended to be used for evaluation purposes only and any commercial use of a
trial licenseis prohibited.

If you are not ready yet to start the trial period, you can opt for the Demo mode. The employment of
Metashape in the Demo mode is not time limited. Several functions, however, are not available in the
Demo mode. These functions are the following:

 savethe project;

« dl export features, including exporting reconstruction results (you can only view a 3D model on the
screen);

To use Metashape in the full function mode for various projects you have to purchase a license. On
purchasing you will get a license code to be entered into the activation dialog of Metashape. Once the
license code is entered you will get full access to all functions of the program and the activation dialog
will no longer appear upon program start, unless the license is deactivated.

Activation procedure

Metashape license activation

M etashape software requires license key (a digital code) to be activated. First of al, make sure that you
have avalid license key or atrial code at hand.

To activate M etashape

1. Launch Metashape software, previously installed on your machine, and go to Help menu for Activate
product... command.

2. InActivation dialog insert license key according to the suggested 5 digit blocks structure. Please note
that license codes does never include zero digit - only letter "O".

3. If the license code has been input correctly, then the OK button will become active. Click on it to
complete the activation procedure. If the button is still grayed out, please make sure that the used
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license key is meant for the product to be activated. For example, alicense key for the Professional
Edition will not allow to activate the Standard Edition, the OK button will remain inactive.

[{ Note

* The node-locked license activation on Windows OS and macOS may require administrator
privileges. During the activation process additional confirmation dialog will appear to apply the
elevated privileges.




Chapter 2. Capturing scenarios

Photographs suitable for 3D model reconstruction in Metashape can be taken by any digital camera (both
metric and non-metric), aslong as specific capturing guidelines arefollowed. This section explainsgeneral
principles of taking and selecting pictures that provide the most appropriate datafor 3D model generation.

IMPORTANT! Make sure to study the following rules and read the list of restrictions before getting out
for shooting photographs.

Equipment

Use adigital camerawith reasonably high resolution (5 MPix or more). It is aso recommended to take
photo in the max possible allowed resolution.

The best choice is 50 mm focal length (35 mm film equivalent) lenses. It is recommended to use focal
length from 20 to 80 mm interval in 35mm equivalent.

Avoid ultra-wide angle and fisheye lenses. The distortion of the lenses used to capture the photos should
be well simulated with the camera model used in the software. Generally, Brown's distortion model
implemented in Metashape workswell for frame cameras. However, since fisheye and ultra-wide angle
lenses are poorly simulated by the mentioned distortion model, it is crucia to choose the proper camera
type in the Camera Calibration dialog prior to processing such data - the software will switch to the
appropriate distortion model.

Fixed lenses are preferred. If zoom lenses are used - focal length should be set either to maximal or to
minimal value during the entire shooting session for more stable results, for intermediate focal lengths
separate camera calibration groups should be used.

1SO should be set to the lowest value, otherwise high 1SO values will induce additional noise to images.

Aperture value should be high enough to result in sufficient focal depth: it isimportant to capture sharp,
not blurred photos.

Shutter speed should not be too slow, otherwise blur can occur due to slight movements.

Using RAW datalosslessly converted to the TIFF filesis preferred, since JPG compression may induce
unwanted noise to the images.

Object/scene requirements

Avoid untextured, shiny, highly reflective or transparent objects. If shiny objects cannot be avoided
wait for a cloudy day to capture them. Direct sunlight leads to patches on most of the surfaces; the light
patches which have moved across the target object during the shooting process will create difficulties
for reconstruction algorithms.

Consider using lighting when shooting underwater or a constant source of light that will increase the
visible distance and quality of the obtained images.

It is recommended to plan the shooting session in such away that unwanted foregrounds, backgrounds,
aswell as moving objects are avoided on the images.

Avoid absolutely flat objects or scenes. The object of interest should take up the maximum proportion
of the image possible. In some cases, the portrait camera orientation option should be considered.
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Capturing scenarios

The shooting scenario depends on the object of the survey (this is a forest area, a detached building, a
monument, etc.).

Aerial photography

In case of aeria photography the overlap requirement can be put in the following figures: 60% of side
overlap + 80% of forward overlap. When making a survey over aforest, it is recommended to increase
the overlap value to 80% and 90% respectively. To achieve better overlap, we can recommend cross-
to-cross routes.

It isimportant plan aflight with a proper elevation model considered.

Do not perform an aerial survey of forest areas lower than 300 meters above the ground. Tree crowns
are moved by the wind hence the results of capturing at low altitude may be problematic for processing
in Metashape, as the software may fail to find common points on the images.

Do not perform an aerial survey of mountain areas |lower than 100 meters above the ground.

Itisnot recommended to perform an aeria survey of the sameareafor thewholeday. Lighting conditions
change during the day. Having the photos of the same territory with different lighting (for example
long shadows from the same structures pointing in completely different directions and having different
shapes) may result in Metashape failing to find common points on the overlapping photos.

Underwater survey

Underwater surveying projects are considerably harder compared to the regular indoor/outdoor image
acquisition procedure due to the very hard environment conditions (viewing distanceislimited, controlled
light environment isalmost not applicable, difficult to place and fix even afew control pointsin scene, may
be hard to repeat the operation). Thereforeit isagood ideato plan the survey carefully before performing
actual shooting session. Taking more images than needed is aways better than having insufficient image
overlap or incomplete dataset.

The optimal cameraroutes are "snake" and "spiral" routes. If possible wait for the calm weather and bright
light - it will allow to increase the visible distance.

Close-range objects scanning

* Number of photos: more than required is better than not enough.

* Number of "blind-zones" should be minimized since Metashape is able to reconstruct only geometry

visible from at |east two cameras.

» Each photo should effectively use the frame size: object of interest should take up the maximum area.

In some cases portrait camera orientation should be used.

» Donot try to placefull object in theimage frame, if some partsare missing it isnot aproblem providing

that these parts appear on other images.

The following figures represent advice on appropriate capturing scenarios:
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Image preprocessing

» Metashape operates with the original images. So do not crop or geometrically transform, i.e. resize
or rotate, the images. Processing the photos which were manually cropped or geometrically warped is
likely to fail or to produce highly inaccurate results. Photometric modifications (such as brightness or
contrast adjustment) do not affect reconstruction results, providing that no hard filters are applied that
could remove minor details on the images (e.g. Gaussian blur filter).

Restrictions

In some cases it might be very difficult or even impossible to build a correct 3D model from a set of
pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs

M etashape can process only unmodified photos as they were taken by a digital photo camera. Processing
the photos which were manually cropped or geometrically warped is likely to fail or to produce highly
inaccurate results. Photometric modifications do not affect reconstruction results.

Lack of EXIF data

Metashape calculates initial values of sensor pixel size and focal length parameters based on the EXIF
data. The better initial approximation of the parameter valuesis, the more accurate autocalibration of the
camera can be performed. Therefore, reliable EXIF datais important for accurate reconstruction results.
However 3D scene can also be reconstructed in the absence of the EXIF data. In this case Metashape
assumesthat focal length in 35 mm equivalent equalsto 50 mm and tries to align the photosin accordance
with this assumption. If the correct focal length value differs significantly from 50 mm, the alignment can
giveincorrect resultsor evenfail. In such casesit isrequired to specify initial cameracalibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are
given in the Camera calibration section.

Lens distortion

The distortion of the lenses used to capture the photos should be well simulated with the camera model
used in the software. Generally, Brown'sdistortion model implemented in Metashape workswell for frame
cameras. However, since fisheye/ultra-wide angle lenses are poorly simulated by the mentioned distortion
model, it is crucial to choose proper cameratypein Camera Calibration dialog prior to processing of such
data - the software will switch to the appropriate distortion model.

Lens calibration

It is possible to use Metashape for automatic lens calibration. Metashape uses LCD screen as acalibration
target (optionally it ispossibleto use aprinted chessboard pattern, providing that itisflat and all itscellsare
squares). Lens calibration procedure supports estimation of the full camera calibration matrix, including
non-linear distortion coefficients. The details of camera models are given in the Appendix D, Camera
model s section.

4 Note

 Lenscalibration procedure can usually be skipped in common workflow, as M etashape cal cul ates
the calibration parameters automatically during Align Photos process. However, if the alignment
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results are unstable, for example, due to the lack of the tie points between the images, the lens
calibration may be useful.

The following camera calibration parameters can be estimated:

f
Focal length measured in pixels.

CX, cy
Principal point coordinates, i.e. coordinates of lensoptical axisinterceptionwith sensor planein pixels.

b1, b2
Affinity and Skew (non-orthogonality) transformation coefficients.

k1, k2, k3, k4
Radia distortion coefficients.

pl, p2
Tangential distortion coefficients.

Before using lens calibration tool a set of photos of calibration pattern should be loaded in Metashape.

To capture photos of the calibration pattern:

1. Select Show Chesshoard... command from the Camera submenu in the Tools menu to display the
calibration pattern.

2. Use mouse scroll wheel to zoom infout the calibration pattern. Scale the calibration pattern so that
the number of squares on each side of the screen would exceed 10.

3. Captureaseries of photos of the displayed calibration pattern with the camerafrom slightly different
angles, according to the guidelines, outlined below. Minimum number of photos for a given focal
length is 3.

4. When calibrating zoom lens, change the focal length of the lens and repeat the previous step for other
focal length settings.

5. Click anywhere on the calibration pattern or press Escape button to return to the program.
6. Upload the captured photos to the computer.

When capturing photos of the calibration pattern, try to fulfill the following guidelines:

» Make sure that the focal length keeps constant throughout the session (in case of zoom lens).
» Avoid glare on the photos. Move the light sources away if required.

» Preferably, the whole area of the photos should be covered by calibration pattern. Move the camera
closer to the LCD screen if required.

Toload photos of the calibration pattern:

1 Create new chunk using & Add Chunk toolbar button on the Workspace pane or selecting Add Chunk

command from the Workspace context menu (available by right-clicking on the root element on the
Workspace pane). See information on using chunks in Using chunks section.

2.  Select Add Photos... command from the Workflow menu.
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3. Inthe Open dialog box, browse to the folder, containing the photos, and select files to be processed.
Then click Open button.

4. Loaded photoswill appear in the Photos pane.

[{ Note

* Open any photo by double clicking on its thumbnail in the Photos pane. To obtain good
calibration, the photos should be reasonably sharp, with crisp boundaries between cells.

¢ Unwanted photos, can easily be removed at any time.

« Before calibrating fisheye lens set the corresponding Camera Type in the Camera Calibration...
dialog available from the Tools menu. See information on other camera calibration settings in
Camera calibration section.

To calibrate camera lens
1. Select Calibrate Camera... command from the Camera submenu in the Tools menu.

2. Inthe Calibrate Camera dialog box, select the desired calibration parameters. Click OK button when
done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

4. Thecalibration results will appear on the Adjusted tab of the Camera Calibration... dialog available
from the Tools menu. The adjusted values can be saved to file by using Save button on the Adjusted
tab. The saved lens calibration data can later be used in another chunk or project, providing that the
same cameraand lensis used.

[{ Note

« After the calibration parametersfor the lens are saved, the actual image set captured by the same
camera and lens can be processed in a separate chunk. To protect the calibration data from being
refined during Align Photos process one should check Fix calibration box on the Initial tab for
the chunk with the datato be processed. In this caseinitial calibration valueswill not be changed
during Align Photos process.

After calibration is finished the following information will be presented:
Detected chessboard corners are displayed on each photo (the photo can be opened by double clicking on
its name in the Photos pane). It is preferable when the majority of the corners were detected correctly. For

each detected corner the reprojection error between the detected corner position and estimated position
according to the calculated calibration is also displayed. The errors are scaled x20 times for display.

Excessive image elimination

Reduce overlap feature is made for analyzing excessive image sets to understand which images are useful
and which are redundant and may be disabled or removed.

1. Align photos using entire dataset and build rough mesh model from the tie point cloud.

2. Select Reduce Overlap dialog available from the Tools menu.

10
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3. Choose parameters in Reduce Overlap dialog box.
4. Click OK button.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

6. After the operation is finished al the cameras which are not included into optimal subset will get
disabled.

Reduce overlap parameters

Surface coverage:

"Reduce overlap" dialog
Reduce overlap dialog parameters:

Focus on selection
To consider only selected triangles of the polygonal model as target for reconstruction. Cameras that
do not have any of the selected polygons in the field of view would be automatically disabled.

Surface coverage
Number of cameras observing each point from different angles.

11



Chapter 3. General workflow

Processing of images with Metashape includes the following main steps:
* loading images into Metashape;
* inspecting loaded images, removing unnecessary images;

+ aligning images,

building point cloud;

building mesh (3D polygona modd!);

 generating texture;

* exporting results.

If Metashape is used in the full function (not Demo) mode, intermediate results of the image processing

can be saved at any stage in the form of project files and can be used later. The concept of projects and
project filesis explained in the Saving intermediate results section.

Preferences settings

M etashape settings are available in the Metashape Preferences dialog window. To change the default
program settings for your projects select Preferences... command from the Tools menu (on macOS select
Preferences... command from the Metashape menu).
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General GPU  Appearance  Mavigation  Advanced

User Interface

Language: English

Default view: Tie Points
Theme: Dark

Shortouts:

Sterenscopic Display

Mode: Anaglyph

Paralla: 1.0

Miscellaneous

C:\WUsersYog. tet

"Metashape Preferences’ dialog (General tab)
The following settings are available in the Metashape Preferences dialog window:
General tab
The GUI language can be selected from the available list: English, Chinese, French, German, Italian,
Japanese, Russian, Spanish.

The GUI appearance can be set in the Theme, the available options are Dark, Light and Classic. The
theme set by default in Metashape Standard edition is Dark.
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The representation of the project can be selected from the Default view list. This parameter indicates
how the project isfirst represented when opened in Metashape. The available options are: Tie points,
Point cloudor Model.

To enable stereo mode in Metashape, select the appropriate Stereoscopic Display mode. For more
information about stereo mode in M etashape see Stereoscopic mode.

Shortcuts for the menu and GUI commands can be adjusted via Customize... button.

It is possible to indicate the path to the Metashape log file, that can be shared with Agisoft support
team in case any problem arises during the data processing in M etashape.

GPU tab
Metashape exploits GPU processing power that speeds up the process significantly. The list of all
detected GPU devicesis presented on the GPU tab. To use GPU during M etashape processing enable
available GPU(s). The option to use CPU can aso be selected on this tab. More information about
supported GPU(s) is available in the GPU recommendations section.

In order to optimize the processing performance it is recommended to disable Use CPU when
performing GPU accelerated processing option when at least one discrete GPU is enabled.

Appearance tab
Customization of theinterface el ementsis available on the Appearancetab. For example, itispossible
to change the background color and parameters for the bounding box inthe Model view, set color and
thicknessfor seamlinesin Ortho view, change the settings for displaying masksin Photo view and etc.

Navigation tab
On this tab the parameters of the 3D controller can be adjusted. See the Stereoscopic mode chapter
for additional information.

Advanced tab
To load additional camera data from XMP (camera calibration) enable the corresponding options on
this tab.

Keep depth maps option hel ps save processing time in cases when the point cloud needs to be re-built
(for a part of the project) after itsinitial generation or when both model and point cloud are based
on the same quality depth maps.

Turning on Enable VBO support speeds up the navigation in the Model view for point clouds and
high polygonal meshes.

Fine-level task subdivision option allowsfor internal splitting of sometasksto sub-jobs, thus reducing
the memory consumption during processing of large datasets. The tasks that support fine-level
distribution are: Match Photos, Align Cameras, Build Depth Maps, Build Point Cloud.

M etashape allows for incremental image alignment, that can be useful in case of some datamissing in
theinitially aligned project. If this may be the case switch on Keep key points option before the initial
processing of the datais started (see Aligning photos section).

Loading source data

This section provides information on how to add source data into a Metashape project and inspect them
in order to ensure good quality of the processing results as well as on how to work with image groups to
conveniently operate with the images in a huge dataset. Further subsections describe details on loading
various specific types of data for processing in Metashape software.
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Adding images

Before starting any operation it is necessary to point out which images will be used as a source for
photogrammetric processing. In fact, images themselves are not loaded into Metashape until they are
needed. So, when Add photos command is used, only the links to the image files are added to the project
contents to indicate the images that will be used for further processing.

Add Folder command is also available in Metashape for importing images into the project. It is used to
convenient load of imagery data from multiple sub-folders of a single folder or when the data should be
organized in a specific way to be correctly interpreted by Metashape.

Metashape uses full color range for image matching operation and does not downsample the color
information to 8 bit. The point cloud points and texture would also have the bit depth corresponding to the
original images, providing that they are exported in the formats that support non 8-bit colors.

Toload a set of images

L Select Add Photos... command from the Workflow menu or click Add Photos toolbar button

on the Workspace pane.

2. In Add Photos dialog box browse to the folder containing the images and select files to be processed.
Then click Open button.

3. Selected images will appear on the Workspace pane.
£ Note

» Metashape accepts the following image formats: JPEG (*.jpg, *.jpeg), JPEG 2000 (*.jp2, *.j2k),
JPEG XL (*.jxI), TIFF (*.tif, *.tiff), Digital Negative (*.dng), PNG (*.png), OpenEXR (*.exr),
BMP (*.bmp), TARGA (*.tga), Portable Bit Map (*.pgm, *.ppm), Norpix Sequence (*.seq),
AscTec Therma Images (*.ara) and JPEG Multi-Picture Format (*.mpo). Image files in any
other format will not be displayed in the Add Photos dialog box. To work with such imagesit is
necessary to convert them to one of the supported formats.

If some unwanted images have been added to the project, they can be easily removed at any moment.

Toremove unwanted images
1. Onthe Workspace pane select the cameras to be removed.

2. Right-click on the selected cameras and choose Remove Items command from the opened context

menu, or click X Remove Items toolbar button on the Workspace pane. Selected images will be
removed from the working set.

Working with image groups

To manipulate the datain achunk easily, e.g. to apply disable/enable functions to several cameras at once,
images in a chunk can be organized in image groups.

To move imagesto aimage group

1. On the Workspace pane (or Photos pane) select the images to be moved.

2. Right-click on the selected images and choose Move Images - New Image Group command from the
opened context menu.
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3. A new group will be added to the active chunk structure and selected photos will be moved to that
group.

4. Alternatively selected images can be moved to a image group created earlier using Move Images -
Image Group - Group_name command from the context menu.

Automatic grouping images isimplemented in Metashape. It is possible to group images according to the
calibration data or by the capture date.

To arrange images to groups automatically

1. Right-click on the Images folder on the Workspace pane.

2. Enable checkbox for Calibration group or/and Capture date in the Group Images dialog window.
3. Click OK button.

4. New groups will be added to the active chunk.

£ Note

« To automatically delete groups that do not contain images, enable Remove empty image groups
optioninthe Group Imagesdial og window. Then the program will automatically check theimage
groups in the chunk and del ete them.

Inspecting loaded images

L oaded images are displayed on the Workspace pane along with flags reflecting their status.
The following flags can appear next to the cameralabel:

NC (Not calibrated)
Notifiesthat the EXIF dataavailablefor theimageisnot sufficient to estimate the camerafocal length.
In this case Metashape assumes that the corresponding photo was taken using 50mm lens (35mm
film equivalent). If the actual focal length differs significantly from this value, manual calibration is
recommended. More details on manual camera calibration can be found in the Camera calibration
section.

NA (Not aligned)
Notifies that exterior camera orientation parameters have not been estimated for the image yet.

Exterior cameraorientation parameters are estimated at Align Photos stage or can beloaded vialmport
Cameras option.

=]
Notifies that Camera Sation type was assigned to the group.

Image quality

Poor input, e. g. vague photos, can influence the alignment results and the texture quality badly. To help to
exclude poorly focused images from processing M etashape suggests automatic image quality estimation
feature. Imageswith quality value of lessthan 0.5 units are recommended to be disabled and thus excluded

from aligment process nad texture generation procedure. To disable a photo use @ Disable button from
the Photos pane toolbar.
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M etashape estimates image quality for each input image. The value of the parameter is calculated based
on the sharpness level of the most focused part of the picture.

To estimate image quality

1 Switch to the detailed view in the Photos pane using == Details command from the Change menu

on the Photos pane toolbar.
2. Select all photos to be analyzed on the Photos pane.

3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the
context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be
displayed in the Quality column on the Photos pane.

Camera station data

If al the images or a subset of images were captured from one camera position - camera station, for
M etashape to process them correctly it is obligatory to move the cameras, corresponding to those images,
to acamera group and mark the group as Sation. It isimportant that for all the imagesin a Station group
distances between camera centers were negligibly small compared to the minimal distance to the object
from the cameras in the group.

To mark group as camera station, right click on the camera group name and select Set Group Type
command from the context menu.

Photogrammetric processing will require at | east two camerastationswith overlapping imagesto be present
in achunk. A panoramic picture, however, can be exported for the data captured from only one camera
station. Refer to Exporting results section for guidance on panorama export.

Video data

M etashape allowsfor video data processing aswell, which can be beneficial for quick inspection scenarios,
for example. The video is to be divided into frames which will be further used as source images for 3D
reconstruction.

Toimport avideofile

1. Select Import Video... command from the File menu.

2. Inthe Import Video dialog inspect the video and set the output folder for the frames .
3.  Set thefilename pattern for the frames and indicate the frame extraction rate.

4. Toimport part of the video, specify the parameters: Start fromand End at.

5. Click OK button for the frames to be automatically extracted and saved to the designated folder. The
images extracted from the video will be automatically added to the active chunk.

4 Note

« In Metashape you can choose the automatic frame step (Small, Medium, Large) or set the
parameter manually via Custom option. Once the parameter value is set, the program calcul ates
the shift for the frames to be extracted. For Small value, the shift of about 3% of the image width
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will be taken into account. For Medium, it corresponds to 7% and for Large - 14% of the image
width.

After the frames have been extracted you can follow standard processing workflow for the images.

Aligning photos

The camera position at the time of image capture is defined by the interior and exterior orientation
parameters.

Interior orientation parameters include camera focal length, coordinates of the image principal point and
lens distortion coefficients. Before starting processing in Metashape the following configuration steps
should be performed:

» Separate calibration groups should be created for each physical camera used in the project. It is aso
recommended to create a separate calibration group for each flight or survey. For details see Camera
groups subsection of Loading source data.

* For each calibration group initial approximation of interior orientation parameters should be specified.
In most casesthisisdone automatically based on EX1F metadata. When EXIF metadataisnot available,
initial interior orientation parameters needs to be configured according to the camera certificate.

Exterior orientation parametersdefine the position and orientation of the camera. They are estimated during
image alignment and consist of 3 translation components and 3 Euler rotation angles.
Exterior and interior image orientation parameters are cal cul ated using aerotriangul ation with bundl e block

adjustment based on collinearity equations.

The result of this processing step consists of estimated exterior (translation and rotation) and interior
camera orientation parameters together with a tie point cloud containing triangulated positions of key
points matched across the images.

Toalign a set of photos
1. Sdect Align Photos... command from the Workflow menu.
2. Inthe Align Photos dialog box select the desired alignment parameters. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

After alignment is compl eted, computed camera positions and atie point cloud will be displayed in Model
view. You can inspect alignment results and remove incorrectly positioned cameras, if any. To see the
matches between any two images use View Matches... command from the image context menu in the
Photos pane.

Incorrectly positioned cameras can be realigned.

Torealign a subset of images

1. Reset alignment for incorrectly positioned cameras using Reset Camera Alignment command from
the photo context menu.

2. Select imagesto be realigned and use Align Selected Cameras command from the context menu.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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When the alignment step is compl eted, the tie point cloud and estimated camera positions can be exported
for processing with another software if needed.

To improve alignment results it may be reasonable to exclude poorly focused images from processing
(read more in Image quality section).

Alignment parameters

* General

Accuracy: High
Estimated

save project after each step

* Advanced

Key point limit: 40,000
Tie point limit: 10,000
Apply masks to:

Guided image matching

Adaptive camera model fitting

Ok

"Align Photos' dialog

The following parameters control the image matching and alignment procedure and can be changed in the
Align Photos dialog box:

Accuracy
Higher accuracy settings help to obtain more accurate camera position estimates. Lower accuracy
settings can be used to get the rough estimation of camera positionsin a shorter period of time.

While at High accuracy setting the software workswith the photos of the original size, Medium setting
causes image downscaling by factor of 4 (2 times by each side), at Low accuracy source files are
downscaled by factor of 16, and Lowest value means further downscaling by 4 times more. Highest
accuracy setting upscales the image by factor of 4. Since tie point positions are estimated on the
basis of feature spots found on the source images, it may be meaningful to upscale a source photo
to accurately localize atie point. However, Highest accuracy setting is recommended only for very
sharp image data and mostly for research purposes due to the corresponding processing being quite
time consuming.
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Generic preselection
The alignment process of large photo sets can take a long time. A significant portion of this time
period is spent on matching of detected features across the photos. Image pair presel ection option may
speed up this process due to selection of a subset of image pairs to be matched.

In the Generic preselection mode the overlapping pairs of photos are selected by matching photos
using lower accuracy setting first.

Reference preselection
The Estimated preselection mode takes into account the calculated exterior orientation parameters
for the aligned cameras. That is, if the alignment operation has been already completed for the project,
the estimated camera locations will be considered when the Align Photos procedure is run again with
the Estimated presel ection selected.

When using Sequential preselection mode the correspondence between the images is determined
according to the sequence of photos (the sequence number of the image) it is worth noting that with
this adjustment, the first with the last images in the sequence will aso be compared.

Reset current alignment
If thisoption is checked, all thetie, and key, and matching points will be discarded and the alignment
procedure will be started from the very beginning.

Save project after each step
Allowsto continue the processing after unexpected program termination (crash, shut down, etc) from
the latest completed sub-task, when the project is opened again for the next time.

Additionally the following advanced parameters can be adjusted.

Key point limit
The number indicates upper limit of feature points on every image to be taken into account during
current processing stage. Using zero value allows Metashape to find as many key points as possible,
but it may result in abig number of less reliable points.

Tiepoint limit
The number indicates upper limit of matching points for every image. Using zero value doesn't apply
any tie point filtering.

Apply mask to

If apply mask to key points option is selected, areas previously masked on the photos are excluded
from feature detection procedure. Apply mask to tie points option means that certain tie points are
excluded from alignment procedure. Effectively thisimpliesthat if some areais masked at least on a
single photo, relevant key points on the rest of the photos picturing the same areawill be also ignored
during alignment procedure (atie point is a set of key points which have been matched as projections
of the same 3D point on different images). This can be useful to be able to suppress background in
turntable shooting scenario with only one mask. For additional information on the usage of masks
please refer to the Using masks section.

Exclude stationary tie points
Excludes tie points that remain stationary across multiple different images. This option enables
alignment without masks for datasets with a static background, e.g. in a case of a turntable with a
fixed camera scenario. Also enabling this option will help to eliminate false tie points related to the
camera sensor or lens artefacts.

Guided image matching
This option allows to effectively boost the number of keypoints per image as if the value of Key
point limit was straightforwardly increased, but without significant growth of processing time. Using
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this parameter can improve results for images with vegetation (wooded terrain, grass, cornfields
and so on), spherical cameras and high resolution images (captured by professional grade cameras,
satellites or acquired by high-resolution scanning of the archival aerial images). To enable Guided
image matching, check corresponding option in Align Photos dialog and adjust Key point limit per
Mpx if needed. The number of detected points per image is calculated as (Keypoint limit per Mpx) *
(image size in Mpx). Small fraction will be extensively matched and used as guidance for matching
of remaining points.

Adaptive camera model fitting

This option enables automatic selection of camera parametersto beincluded into adjustment based on
their reliability estimates. For data sets with strong camera geometry, like images of a building taken
from all the sides around, including different levels, it helps to adjust more parameters during initial
camera alignment. For data sets with weak camera geometry , like atypical aeria data set, it helps
to prevent divergence of some parameters. For example, estimation of radial distortion parameters
for data sets with only small central parts covered by the object is very unreliable. When the option
is unchecked, Metashape will refine only the fixed set of parameters. focal length, principal point
position, three radial distortion coefficients (K1, K2, K3) and two tangential distortion coefficients
(P1, P2).

4 Note

e Tie point limit parameter allows to optimize performance for the task and does not generally
effect the quality of the further model. Recommended value is 10 000. Too high or too low tie
point limit value may cause some parts of the point cloud model to be missed. The reason isthat
M etashape generates depth maps only for pairs of photos for which number of matching pointsis
abovecertain limit. Thislimit equalsto 100 matching points, unless moved up by thefigure"10%
of the maximum number of matching points between the photo in question and other photos,
only matching points corresponding to the area within the bounding box being considered.”

< The number of tie points can be reduced after the alignment process with Tie Points - Thin Point
Cloud command available from Tools menu. As aresultstie point cloud will be thinned, yet the
alignment will be kept unchanged.

Components

Someimage subsets may be not aligned asthe result of the Align Photos operation, if the sufficient amount
of tie points was not detected between such subsets. Such subsets which are not aligned with the main
subset will be grouped into individually aligned parts - Components.

The components into which the camera alignment have been split after the Align Photos operation will be
displayed in the chunk's contents of the Workspace pane inside the Components fol der.

Incremental image alignment

In case some extra images should be subaligned to the set of already aligned images, you can benefit
from incremental image alignment option. To make it possible, two rules must be followed: 1) the scene
environment should not have changed significantly (lighting conditions, etc); 2) do not forget to switch on
Keep key points option in the Preferences dialog, Advanced tab BEFORE the whole processing is started.

To subalign some extra images added to the chunk with already aligned set of
images

1. Add extraphotos to the active chunk using Add photos command from the Workflow menu.
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2. Open Align photos dialog from the Wor kflow menu.

3. Set alignment parameters for the newly added photos. IMPORTANT! Uncheck Reset alignment
option.

4. Click OK. Metashapewill consider existing key pointsand try to match them with key points detected
on the newly added images.

Point cloud generation based on imported camera data

M etashape supportsimport of exterior and interior camera orientation parameters. Thus, if precise camera
data is available for the project, it is possible to load them into Metashape along with the photos, to be
used asinitia information for 3D reconstruction job.

Toimport exterior and interior camera parameters
1. Select Import Cameras command from the File menu.

2. Select the format of the file to be imported.

3. Browsetothefile and click Open button.

4. The datawill be loaded into the software. Camera calibration data can be inspected in the Camera
Calibration dialog, Adjusted tab, available from Tools menu.

Camera data can be loaded in one of the following formats: Agisoft (*.xml), PATB Camera Orientation
(*.ori), BINGO (*.dat), Inpho Project File (*.prj), Blocks Exchange (*.xml), Bundler (*.out), Realviz
RZML (*.rzml), N-View Match (*.nvm), Alembic (*.abc), Autodesk FBX (*.fbx), VisionMap Detailed
Report (*.txt).

Once the data is loaded, Metashape will offer to build point cloud. This step involves feature points
detection and matching procedures. As aresult, a Tie Points cloud - 3D representation of the tie-points
data, will be generated. Build Point Cloud command isavailable from Tools - Tie Points menu. Parameters
controlling Build Point Cloud procedure are the same as the ones used at Align Photos step (see above).

Building point cloud

M etashape allows to create a point cloud based on the calculated exterior and interior image orientation
parameters.

Point cloud generation is based on depth maps calculated using dense stereo matching. Depth maps
are calculated for the overlapping image pairs considering their relative exterior and interior orientation
parameters estimated with bundle adjustment. Multiple pairwise depth maps generated for each camera
are merged together into combined depth map, using excessive information in the overlapping regions to
filter wrong depth measurements.

Combined depth maps generated for each camera are transformed into the partial point clouds, which are
then merged into afinal point cloud with additional noisefiltering step applied in the overlapping regions.
The normalsin the partial point clouds are calculated using plane fitting to the pixel neighborhood in the
combined depth maps, and the colors are sampled from the images.

For every point in the final point cloud the number of contributing combined depth mapsis recorded and
stored as aconfidence value. This confidence value can be used later to perform additional filtering of low
confidence points using the Filter by Confidence... command from the Tools > Point Cloud menu.
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Metashape tends to produce extra point clouds, which are of aimost the same density, if not denser, as
LIDAR point clouds. A point cloud can be edited within Metashape environment and used as a basis for
such processing stages as Build Model. Alternatively, the point cloud can be exported to an external tool
for further analysis.

To build a point cloud

L Check the reconstruction volume bounding box. To adjust the bounding box use the Resize

Region, & Move Region and gg‘ Rotate Region toolbar buttons. To resize the bounding box, drag
corners of the box to the desired positions; to move - hold the box with the left mouse button and
drag it to the new location.

2. Select the Build Point Cloud... command from the Wor kflow menu.

3. Inthe Build Point Cloud dialog box select the desired reconstruction parameters. Click OK button
when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4 Note

« More than one instance of Point cloud can be stored in one chunk. In case you want to save
current Point cloud instance and build new one in current chunk, right-click on Point cloud and
uncheck Set as default option. To save current Point cloud instance and edit its copy, right-click
on Point cloud and choose Duplicate option.

Build Point Cloud parameters

* General
Source data: Depth maps

Quality: High

* Advanced

Depth filtering:

"Build Point Cloud" dialog
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Sour ce data
Specifies the source (Depth Maps, Model or Tiled model) for the point cloud generation procedure.

If Depth Maps was sel ected as the source data then the following parameters can be adjusted:

Quality
Specifies the desired quality of the depth maps generation. Higher quality settings can be used to
obtain more detailed and accurate geometry, but they requirelonger timefor processing.Interpretation
of the quality parameters hereissimilar to that of accuracy settings given in Photo Alignment section.
Theonly differenceisthat in this case UltraHigh quality setting means processing of original photos,
while each following step implies preliminary image size downscaling by factor of 4 (2 times by each
side).

Reuse depth maps
Depth maps available in the chunk can be reused for the point cloud generation operation. Select
respective Quality and Depth filtering parameters values (see info next to Depth maps label on the
Workspace pane) in Build Point Cloud dialog and then check Reuse depth maps option.

Save project after each step
Allowsto continue the processing after unexpected program termination (crash, shut down, etc) from
the latest completed sub-task, when the project is opened again for the next time.

Depth filtering modes
At the stage of point cloud generation reconstruction Metashape calculates depth maps for every
image. Due to some factors, like noisy or badly focused images, there can be some outliers among
the points. To sort out the outliers Metashape has several built-in filtering algorithms that answer the
challenges of different projects.

If there are important small details which are spatially distinguished in the scene to be
reconstructed, then it is recommended to set Mild depth filtering mode, for important features
not to be sorted out as outliers. This value of the parameter may also be useful for aerial projects
in case the area contains poorly textured roofs, for example. Mild depth filtering mode is also
required for the depth maps based mesh reconstruction.

If the area to be reconstructed does not contain meaningful small details, then it is reasonable
to choose Aggressive depth filtering mode to sort out most of the outliers. This value of the
parameter normally recommended for aerial data processing, however, mild filtering may be
useful in some projects as well (see poorly textured roofs comment in the mild parameter value
description above).

Moderate depth filtering mode brings results that are in between the Mild and Aggressive
approaches. Y ou can experiment with the setting in case you have doubts which mode to choose.

Additionally depth filtering can be Disabled. But this option is not recommended as the resulting
point cloud could be extremely noisy.

The filtering modes control noise filtering in the raw depth maps. This is done using a connected
component filter which operates on segmented depth maps based on the pixel depth values. The
filtering preset control a maximum size of connected components that are discarded by the filter.

Calculate point colors
This option can be unchecked in case the points color is not of interest. This will allow to save up
processing time.

Calculate point confidence
If the option is enabled, the Metashape will count how many depth maps have been used to generate
each point cloud point. This parameter can used for point cloud filtering (see Editing point cloud).
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Replace default point cloud
Default point cloud will be replaced in the project if this option is enabled.

[{ Note

 Stronger filter presets remove more noise, but also may remove useful information in case there
are small and thin structures in the scene.

If Modédl or Tiled model were selected as the source data then the following parameters can be adjusted:

Uniform point spacing (m)
Specifies the desired distance between points of the point cloud to be generated.

Estimated point count
Defines the expected number of points to be generated.

Import point cloud

M etashape allows to import a point cloud that can be used in the following processing steps. If you want
to upload a point cloud got from some external source (photogrammetry technology, laser scanning, etc),
you can use Import points command from the File menu. In the Import points dialog browse to afilein
one of the supported formats and click Open button.

Point cloud can beimported in one of thefollowing formats: Wavefront OBJ (*.obj), Stanford PLY (*.ply),
ASPRS LAS (*.las), LAZ (*.laz), ASTM E57 (*.€57), ASCII PTS (*.pts, *.pts.gz), PTX (*.ptx), Point
Cloud Data (*.pcd).

In Import Points dialog window specify Direction (Generic, Origin, Trajectory file) and avaue for Local
surface neighborsfor thefollowing formats: ASTM E57 (*.€57), ASCII PTS (*.pts, *.pts.gz), PTX (*.ptx).
If the point cloud was recorded in a structured form, then the Direction - Origin parameter should be used.
If the point cloud was obtained in an unstructured form, then use Direction - Generic. In order to determine
the normal of apoint in apoint cloud, Metashape approximate the local surface of the model with aplane.
The direction of the plane is determined by the nearby neighbors of a given point. The number of nearby
points to consider is determined by Local surface neighbors parameter. If the cloud is very noisy, 28
default neighbors may not be enough to confidently determine the normals. For such point clouds, it is
worth increasing the number of neighbors under consideration to 100. Increasing the number of neighbors
will slow down the calculation, smooth out the normals at the corners, but will help avoid noise. In some
cases, increasing the number of neighbors can help avoid large inverted plots.

Building model

M etashape can reconstruct polygonal model based on tie points, point cloud and depth maps.

To build amodd

1. Check the reconstruction volume defined by the bounding box. If the default bounding box size and
orientation does not cover the entire area of interest or, in contrary, if a smaller volume should be
reconstructed, use manual tools (resize region, move region, rotate region) to adjust the working
volume.

To adjust the bounding box manually, use the Resize Region, % Move Region and 2?’ Rotate
Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired
positions - only part of the scene inside the bounding box will be reconstructed. If the Height field
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reconstruction method is to be applied, it is important to control the position of the red side of the
bounding box: it definesreconstruction plane. In this case make sure that the bounding box iscorrectly

oriented.
2. Select the Build Modél... command from the Wor kflow menu.

3. Inthe Build Model dialog box select the desired reconstruction parameters. Click OK button when
done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4 Note

< More than one instance of Model can be stored in one chunk. In case you want to save current
Model instance and build new one in current chunk, right-click on Model and uncheck Set as
default option. In case you want to save current Model instance and edit its copy, right-click on
Model and choose Duplicate option.

Build Model parameters

* General

Source data: Depth maps
Surface type:

Quality: High

Face count: High

Save project after each step

* Advanced

Interpolation: Enabled (default)

Depth filtering: Mild

"Build Model" dialog

Metashape supports several reconstruction methods and settings, which help to produce optimal
reconstructions for a given data set.
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Sour ce data
Specifies the source for the model generation procedure.

» Tie pointscan be used for fast 3D model generation based solely on the tie point cloud.

» Point cloud setting will result in longer processing time but will generate high quality output based
on the previously reconstructed or imported point cloud.

» Depth maps setting allows to use all the information from the input images more effectively
and is less resource demanding compared to the point cloud based reconstruction. The option
is recommended to be used for Arbitrary surface type reconstruction, unless the workflow used
assumes point cloud editing prior to the model reconstruction.

Surfacetype

» Arbitrary surface type can be used for modeling of any kind of object. It should be selected for
closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the
object being modeled, which comes at a cost of higher memory consumption.

» Height field surface type is optimized for modeling of planar surfaces, such as terrains or
basereliefs. It should be selected for aerial photography processing as it requires lower amount of
memory and allows for larger data sets processing.

Quality
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a
source option. Higher quality settings can be used to obtain more detailed and accurate geometry, but
they require longer time for the processing.

Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo
Alignment section. The only differenceisthat in this case UltraHigh quality setting means processing
of original photos, while each following step implies preliminary image size downscaling by factor
of 4 (2 times by each side). For depth maps based model generation Mild filtering option is used by
default, unless Reuse depth maps option is enabled. Aggressive filtering can be used if the excessive
geometry (such asisolated model components around the reconstructed object) is observed, however,
some fine level thin elements may be lost due to this depth filtering mode selection.

Face count

Specifies the maximum number of polygons in the fina model. Suggested values (High, Medium,
Low) present optimal number of polygonsfor amodel of acorresponding level of detail. For the point
cloud based reconstruction they are cal culated based on the number of pointsin the source point cloud:
theratio is 1/5, 1/15, and 1/45 respectively. It is still possible for a user to indicate the target number
of polygonsin thefinal model through the Custom value of the Face count parameter. Please note that
while too small number of polygonsis likely to result in too rough model, too huge custom number
(over 10 million polygons) is likely to cause model visualization problemsin external software.

Save project after each step
Allowsto continue the processing after unexpected program termination (crash, shut down, etc) from
the latest completed sub-task, when the project is opened again for the next time.

Additionally the following advanced parameters can be adjusted.

I nterpolation
If interpolation mode is Disabled it leads to accurate reconstruction results since only areas
corresponding to point cloud points are reconstructed. Manual hole filling is usually required at the
post processing step.With Enabled (default) interpolation mode Metashape will interpolate some
surface areas within a circle of a certain radius around every point cloud point. As a result some
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holes can be automatically covered. Y et some holes can still be present on the model and are to be
filled at the post processing step. In Extrapolated mode the program generates holeless model with
extrapolated geometry. Large areas of extra geometry might be generated with this method, but they
could be easily removed later using selection and cropping tools.

Depth filtering modes
This option is available if Depth Maps was selected as the Source data. The filtering modes control
noise filtering in the raw depth maps. Thisis done using a connected component filter which operates
on segmented depth maps based on the pixel depth values. The filtering preset control a maximum
size of connected components that are discarded by the filter.

If there are important small details which are spatially distinguished in the scene to be
reconstructed, then it is recommended to set Mild depth filtering mode, for important features
not to be sorted out as outliers. This value of the parameter may also be useful for aerial projects
in case the area contains poorly textured roofs, for example. Mild depth filtering mode is also
required for the depth maps based mesh reconstruction.

If the area to be reconstructed does not contain meaningful small details, then it is reasonable
to choose Aggressive depth filtering mode to sort out most of the outliers. This value of the
parameter normally recommended for aerial data processing, however, mild filtering may be
useful in some projects as well (see poorly textured roofs comment in the mild parameter value
description above).

Moderate depth filtering mode brings results that are in between the Mild and Aggressive
approaches. Y ou can experiment with the setting in case you have doubts which mode to choose.

Additionally depth filtering can be Disabled. But this option is not recommended as the resulting
point cloud could be extremely noisy.

Calculate vertex colors
If source data has color information (point cloud colors or images are present for the depth maps based
calculation) enabling this option would allow to cal cul ate the colorsfor the model vertices and display
the interpolated colors for the model polygons in Shaded view mode.

Use strict volumetric masking

When this option is enabled, space volume covered with mask from at least one photo will be
suppressed. Each mask is strict - so you should use them as little as possible to prevent accidental
suppressing some surface parts. Each mask also makes model reconstruction slower. For example
strict volumetric masks are useful to suppress noise between fingers by masking space between them
from single camera. Also this is useful to suppress textureless background stuck to object contours
- by masking out background from single camera. For additional information on the usage of masks
please refer to the Using masks section. The option is only applicable for the Depth Maps source
option selected.

Reuse depth maps
If available depth maps should be reused for model generation, select respective Quality (seeinfo next
to Depth maps label on the Workspace pane in the chunk's contents) and then check Reuse depth maps
option. The option is applicable to the depth maps based reconstruction method only.

Replace default model
Default model will be replaced in the project if this option is enabled.

4 Note

» Metashape tends to produce 3D models with excessive geometry resolution, so it may be
reasonable to perform model decimation after geometry computation. More information on
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model decimation and other 3D model geometry editing tools is given in the Editing model
geometry section.

Import model

Polygona mesh model can be imported using Import model command from the File menu. The following
import formats are supported: Wavefront OBJ (*.obj), 3DS models (*.3ds), OpenCTM models (*.ctm),
COLLADA (*.dae), Stanford PLY (*.ply), STL models (*.stl), Alembic (*.abc), Autodesk FBX (*.fbx),
Aturodesk DXF (*.dxf), U3D models (*.u3d).

Building model texture

Color calibration

If the lighting conditions have been changing significantly during capturing scenario, it is recommended
to use Calibrate colors option from the Tools menu before Build texture procedure. The option can help
to even brightness and white balance of the images over the data set. Please note that for large data sets
Calibrate colors procedure can turn out to be quite time consuming.

To calibrate colors
1. Select Calibrate colors... command from the Tools menu.

2. Select the desired colors calibration parameters in the Calibrate colors dialog box. Click OK button
when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Color calibration parameters

Parameters
Source data; Tie points

Calibrate white balance

Apply to selected images

"Calibrate Colors" dialog

Sour ce data
Defines what data should be taken as the basis for overlapping areas estimation.
Tie points - the quickest yet the roughest estimation available.

Model - gives more precise results, but only on condition that the surface is detailed enough. This
parameter value is the recommended one if the aim is to calibrate colors to improve the quality of
the model texture.
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Calibrate white balance
Additional option to be switched on if white balance should be evened as well.

In Metashapeit is possibleto manually set color level adjustmentsfor one or moreimages using the Adjust
color levelstool. The Adjust Color Levelstool is available from the selected images context menu in the
Photos pane. If the image is very dark or overexposed, you can manually set adjust the levels for each
channel of theimage in the Color levels dialog of the tool or set the Average value for al channels.

Build Texture

The texture feature allows to build different types of textures for a polygona mesh model.

To generate 3D model texture

1. Setamodel activeto build atexturefor it. Use Set as default command from the model context menu
on the Workspace pane.

2. Select Build Texture... command from the Wor kflow menu.

3. Select the desired texture generation parameters in the Build Texture dialog box. Click OK button
when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Texture generation parameters

* General
Texture type: Diffuse map
Source data: Images

Mapping mode: Generic

Blending mode: Mosaic (default)

Texture sizefcount:

Enable ghaosting filter

Anti-aliasing:

"Build Texture" dialog
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The following parameters control various aspects of texture atlas generation:

Texturetype
Diffuse map - the basic texture that stores the colors of the model surface.

Normal map - texture map that allowsto calculate the illumination of the model parts from different
light sources in the post-processing workflow.

Occlusion map - atexturethat contains pre-cal cul ated shading information from background lighting.

Displacement map - a black-and-white texture where each pixel has a value from 0 to 255. These
values are used to determine the height of each point on the surface of the object.

Sour ce data
Images - alow to build a color texture map (diffuse map) based on the aligned images of the model
or transferred from another model with already generated color texture map.

Orthomosaic - alow to build a color texture map (diffuse map) based on orthomosaic rather than
the original images.

3D mode - the normal and occlusion texture maps can be built based on another model and the
relief of the model specified in the Source data field will be transferred to the current model. Usually
it is recommended to use the more detailed model as a source data for the Normal, Occlusion and
Displacement map generation for the 3D model with the lower polygon count. Normal map option
will not be available in the Source data field, if less than two 3D model instances are present in the
active chunk.

M apping mode
The texture mapping mode determines how the object texture will be packed in the texture atlas.
Proper texture mapping mode selection helps to obtain optimal texture packing and, consequently,
better visual quality of the final model.

The default mode is the Generic mapping mode; it allows to parametrize texture atlas for arbitrary
geometry. No assumptions regarding the type of the scene to be processed are made; program tries
to create as uniform texture as possible.

In the Orthophoto mapping mode the whol e object surfaceistextured in the orthographic projection.
The Orthophoto mapping mode produces even more compact texture representation than the
Adaptive orthophoto mode at the expense of texture quality in vertical regions.

In the Adaptive orthophoto mapping mode the object surface is split into the flat part and vertical
regions. The flat part of the surface is textured using the orthographic projection, while vertica
regions aretextured separately to maintain accurate texture representation in such regions. Wheninthe
Adaptive orthophoto mapping mode, program tends to produce more compact texture representation
for nearly planar scenes, while maintaining good texture quality for vertical surfaces, such aswalls
of the buildings.

Spherical mapping mode is appropriate only to a certain class of objects that have a ball-like form.
It allows for continuous texture atlas being exported for this type of objects, so that it is much easier
to edit it later. When generating texture in Spherical mapping mode it is crucial to set the bounding
box properly. The whole model should be within the bounding box. The red side of the bounding box
should be under the model; it defines the axis of the spherical projection. The marks on the front side
determine the O meridian.

The Single camera mapping mode allows to generate texture from a single image. The image to be
used for texturing can be selected from Texture from: list.
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The Keep uv mapping mode generates texture atlas using current texture parametrization. It can
be used to rebuild texture atlas using different resolution or to generate the atlas for the model
parametrized in the external software. Keep uv option preserves the original number of texture atlas
pages, i.e. Texture count parameter can't be changed.

Blending mode (not used in Single camera mapping mode)
Selectstheway how color values of pixelsfrom different cameraswill be combined in thefinal texture.

M osaic - implies two-step approach: it does blending of low frequency component for overlapping
images to avoid seamline problem (weighted average, weight being dependent on a number of
parameters including proximity of the pixel in question to the center of the image), while high
frequency component, that isin charge of picture details, is taken from a single image - the one that
presents good resolution for the area of interest while the camera view is ailmost along the normal to
the reconstructed surface in that point.

Average - uses the weighted average value of al pixels from individual photos, the weight being
dependent on the same parametersthat are considered for high frequency component in mosaic mode.

Max Intensity - the image which has maximum intensity of the corresponding pixel is selected.
Min I ntensity - the image which has minimum intensity of the corresponding pixel is selected.

Disabled - the image to take the color value for the pixel from is chosen like the one for the high
frequency component in mosaic mode.

Texturesize/ count
Specifies the size (width & height) of the texture atlas in pixels and determines the number of files
for texture to be exported to. Exporting texture to severa files allows to archive greater resolution of
the final model texture, while export of high resolution texture to a single file can fail due to RAM
limitations.

Multi-pagetexture atlas generation issupported for Generic mapping mode only and K eep UV option,
if the imported model contains proper texture layout.

Save project after each step
Allows to continue processing from the previous saved task when reopen the project if there is a
problem during processing related to the unexpected program termination (crash, shut down, etc).

Additionally the following advanced parameters can be adjusted.

Enable holefilling
Thisoption is enabled on default sinceit helps to avoid salt-and-pepper effect in case of complicated
surface with numerous tiny parts shading other parts of the model. Only in case of very specific tasks
might it be recommended to switch the function off.

Enable ghosting filter
In case the scene includes some thin structures or moving objects which failed to be reconstructed
as part of polygona model, it can be useful to switch on this option to avoid ghosting effect on the
resulting texture.

Transfer texture
If thereis atextured model in the chunk, its texture can be reused for another model, for example, if
the model has been decimated. The option isonly available if Model is selected as a Source data.

Anti-aliasing
Option helps to minimize the loss of texture quality when baking textures at such stages as Transfer
Texture, baking vertex colors and building Normal map, Occlusion map, Displacement map. During
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the texture baking the algorithm casts several rays instead of one for each resulting texture pixel, and
then averages the resullt.

4 Note

» HDR texture generation requires HDR photos on input.

To improve resulting texture quality it may be reasonable to exclude poorly focused images from
processing (read more in Image quality section).

View Texture Mapping

View

In Metashape it is possible to analyze Model UV statistic. The datain this dialog box allows to evaluate
the quality of the resulting texture.

To open Texture Mapping dialog window
1. Select View Texture Mapping... command on Model submenu from the Tools menu.

2. Check parameters for the built texture in Texture Mapping dialog box. Use Save Page button to save
data from this page.

Color

Scaling
Overlap

Resolution

Statistics
Fill ratio:

Overlap ratio:

Min scaling:

Maix

scaling:

Min resolution:

Max

resolution:

Page scaling:
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"Texture Mapping" dialog

The texture layout is displayed on the right side of the dialog window and depends on which parameter
is selected in View section. Satistics section presents numerical parameters. The parameters from View
section and corresponding Statistics section values are described below:

View
Color - displaysthe colors of the mesh vertices.

Diffuse map - display the basic texture that stores the colors of the model surface.

Scaling - displaysthe ratio of the area of the texture triangle to its area on the mesh surface. The min
and max scaling values in the Satistics section correspond. The colors display the following: blue -
min scaling, red - max scaling.

Overlap - displays how many pixelsin the atlas correspond to more than one triangle in the mesh.

Resolution - displays the detail as a percentage. It is calculated as the ratio of the number of pixels
for the triangle from the most detailed photo to the area of the triangle in the atlas. In the Statistics
section the percentage (min and max values) is displayed. The colors display the following: blue -
minimal resolution of the texture, red - maximal resolution of the texture, the good enough values
are colored in green.

Statistics
Fill ratio: - displays the percentage of occupied pixels on the atlas page.

Overlap ratio: - vaue of the overlap as a percentage corresponds to Overlap parameter in View
section. Thisvalue will be 0 in anideal case.

Min scaling: - minimum scaling value as a percentage.

Max scaling: - maximum scaling value as a percentage.

Min Resolution: - minimum resolution value as a percentage.
Max Resolution: - maximum resolution value as a percentage.

To save information from each map (Color, Diffuse map, Scaling, Overlap, Resolution) use Save page
button on the lower left corner of the dialog window.

To switch between the pages of the texture atlas use Next page and Previous page buttons at the bottom of
the dialog window. The number of pages corresponds to the number specified in Build texture dial og box.

Building panorama

Metashape is capable of panorama stitching for images taken from the same camera position - camera
station. To indicate for the software that loaded images have been taken from one camera station, one
should move those photos to aimage group and assign Station type to it. For information on image groups
refer to Loading source data section.

To build panorama
1.  Select the Build Panorama command from the Workflow menu.
2. Setting parameters for building panoramain the Build Panorama dialog.

3. Click OK button for starting generate panorama.
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4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

[ Note

 Build Panorama procedure can be performed only for projects saved in .PSX format.

Build panorama parameters

Camera group:  Group 1

Apply to: Active chunk

Blending mode: Maosaic {default)

Enable ghosting filter

Save project after each step

R.egion

Setup boundaries:

"Build Panorama’ dialog

Preview
Camera group - select camera station for building panorama.

Orientation and rotation parameter s - setting orientation and rotation using corresponding buttons
for building panorama.

Parameters
Apply to - select chunk or entire workspace.
Blending mode - selects the method how color values of pixels from different cameras will be
combined in the final panorama (Mosaic, Average, Disabled). Mosaic - implies two-step approach:
it does blending of low frequency component for overlapping images to avoid seamline problem
(weighted average, weight being dependent on a number of parameters including proximity of the
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pixel in question to the center of the image), while high frequency component, that is in charge of
picture details, is taken from a single image - the one that presents good resolution for the area of
interest while the camera view is almost along the normal to the reconstructed surface in that point.
Average - uses the weighted average value of all pixels from individual photos, the weight being
dependent on the same parameters that are considered for high frequency component in mosaic mode.
Disabled - the image to take the color value for the pixel from is chosen like the one for the high
frequency component in mosaic mode.

Enable ghosting filter - in case the scene includes some thin structures or moving objects, it can be
useful to switch on this option to avoid ghosting effect on the resulting panorama.

Save proj ect after each step - allowsto continue the processing after unexpected program termination
(crash, shut down, etc) from the latest completed sub-task, when the project is opened again for the
next time.

Region

Setup boundaries - set boundaries for the region of panoramato be built. Text boxesin thefirst line
(X) dlow to indicate the angle in the horizontal plane and the second line (Y) serves for anglein the
vertical plane limits.

I mage size (pix) - option enables to control the dimensions of the resulting image file.

Saving intermediate results

Certain stages of 3D model reconstruction can take a long time. The full chain of operations could
eventually last for 4-6 hours when building amodel from hundreds of photos. It is hot always possible to
complete al the operationsin one run. Metashape allows to save intermediate results in a project file.

Metashape project archive (PSZ2)

Metashape Archive files (*.psz) may contain the following information:

List of loaded photographs with reference paths to the image files.

Cameraalignment data such as cameraexterior orientation parameters, tie point cloud and set of refined
camera calibration parameters for each calibration group.

Masks applied to the photos in project.
Depth maps for cameras.
Point cloud.

Reconstructed 3D polygonal model with any changes made by user. This includes model and texture
if it was built.

Structure of the project, i.e. number of chunksin the project and their content.

Notethat since M etashape tends to generate extradense point cloudsand highly detailed polygona models,
project saving procedure can take up quite along time.

Metashape project file (PSX)

Y ou can save the project at the end of any processing stage and return to it later. To restart work simply
load the corresponding file into Metashape. Project files can also serve as backup files or be used to save
different versions of the same model.
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Project files use relative paths to reference original photos. Thus, when moving or copying the project file
to another location do not forget to move or copy photographs with all the folder structure involved as
well. Otherwise, Metashape will fail to run any operation requiring source images, although the project
file including the reconstructed model will be loaded up correctly. Alternatively, you can enable Store
absolute image paths option on the Advanced tab of the Preferences dialog available from Tools menu.

Exporting results

M etashape supports export of processing results in various representations: tie points and point clouds,
camera calibration and camera orientation data, model, etc.

Tie point cloud and camera calibration data can be exported right after photo alignment is completed. All
other export options are available after the corresponding processing step.

If you are going to export the results (point cloud / model) for the chunk that is not referenced, please note
that the resulting file will be oriented according to a default coordinate system (see axes in the bottom

right corner of the Model view), i. e. the model can be shown differently from what you see in Metashape
window.

e 19 .
To aign the model orientation with the default coordinate system use “.#* Rotate object button from the

F,
Toolbar. & Move object and “.& Scale object instruments can be used to adjust the size and location of
the unreferenced model.

In some cases editing model geometry in the external software may be required. M etashape supports model
export for editing in external software and then allows to import it back as it is described in the Editing
model geometry section of the manual.

Main export commands are available from the File menu.

Point cloud export

To export tie pointsor point cloud

1. Select Export Point Cloud... command from the File menu.

2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.
3. Inthe Export Points dialog box select desired type of point cloud: Tie points or Point cloud.

4. Indicate export parameters applicable to the selected file type.

5. Click OK button to start export.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

In some casesit may be reasonableto edit point cloud before exporting it. To read about point cloud editing
refer to the Editing point cloud section of the manual.

M etashape supports point cloud export in the following formats:

« Wavefront OBJ (*.obj)
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e Stanford PLY (*.ply)

» XYZ Point Cloud (*.txt)
« ASPRSLAS (*.las)

e LAZ (*.laz)

» Cloud optimized LAZ (*.copc.laz)
« ASTM E57 (*.€57)

» Topcon CL3 (*.cl3)

e ASCII PTS (*.pts)

» Autodesk DXF (*.dxf)
» U3D (*.u3d)

» Adobe PDF (*.pdf)
 Point Cloud Data (*.pcd)

* potree (*.zip)

Agisoft OC3 (*.oc3)
£ Note

¢ Saving color information of the point cloud is not supported by the OBJ and DXF formats.

e Saving point normals information is not supported by the LAS, LAZ, PTS, CL3 and DXF
formats.

Metashape supports direct uploading of the point clouds to the following resources: 4ADMapper (not

supported for tie points), Cesium (not supported for tie points), PointBox, PointScene and Sketchfab. To
publish your point cloud online use Upload Data... command from the File menu.

Tie points and camera calibration, orientation data
export

To export camera calibration and camera orientation data select Export Cameras... command from the
File menu.

M etashape supports camera data export in the following formats:
» Agisoft XML structure (*.xml)

» Bundler (*.out)

* CHAN files (*.chan)

» Boujou (*.txt)
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Realviz RZML (*.rzml)

Omega Phi Kappa (* .txt)

PATB Project (*.pro)

BINGO Project (*.dat)

ORIMA (*.txt)

Maya ASCII (*.ma)

AeroSys Exterior Orientation (*.orn)
Inpho Project File (*.prj)

Summit Evolution Project (*.smtxml)
Blocks Exchange (*.xml)

N-View Match (*.nvm)

Alembic (*.abc)

Autodesk FBX (*.fbx)

Colmap (*.txt)

4 Note

To export tie points data one should choose one of the following export formats in the Export Cameras
dialog: BINGO, ORIMA, PATB, Summit Evolution or Blocks exchange. Tie points can be exported only
along with interior and exterion orientation parameters of the cameras.

Asaresult of export in PATB format, the following files will be written:

» Cameradataexport in Bundler and Boujou file formats will savetie point cloud datain the same

file.

« Cameradataexport in Bundler file format would not save distortion coefficients k3, k4.

example.pro

Project file PATB. It contains information on the units of measurement (microns/millimeters). This
eliminates the ambiguity in interpreting the data on import.

exampleim

File with coordinates of tie points projections on the images.

example.ori

File with the calculated parameters of the exterior orientation for the cameras.

example.at

File with the calculated coordinates of tie points (adjusted terrain coordinates).

4 Note

* *.imand *.con formats are input filesfor PATB and *.ori. and * .at are output formats.
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Asaresult of export in BINGO format, thefollowing fileswill be written to the destination folder: itera.dat
(ITERA file); image.dat IMAGE COORDINATE file); geoin.dat (GEO INPUT file); gps-imu.dat (GPS/
IMU data).

As aresult of export in Summit Evolution format two files will be created (*.cam, *.smtxml). File in
* .cam format includesinformation about cameracalibration parameters. Filein* .smtxml format is Summit
Evolution project file.

To export / import camera calibration data only select Camera Calibration... command from the Tools

menu. Using ="/ H buttonsit is possible to load / save camera calibration datain the following formats:
» Agisoft Camera Calibration (*.xml)

» Ausdtralis Camera Parameters (* .txt)

» Australisv7 Camera Parameters (* .txt)

» PhotoModeler Camera Calibration (*.ini)

» 3DM CalibCam Camera Parameters (*.txt)
» CaCam Camera Calibration (*.ca)

* Inpho Camera Calibration (*.txt)

» USGS Camera Calibration (*.txt)

» Pix4D Camera Calibration (*.cam)

* OpenCV Camera Calibration (*.xml)

» Photomod Camera Calibration (* .x-cam)

» Z/I Distortion Grid (*.dat)

e STMap (*.tif, *.exr)

4 Note

e STMap (*.tif, *.exr) format is only available for export camera calibration result.
Panorama export

To export panorama

1. Select Export > Export Panorama command from the File menu.
2. Set exporting parameters and click Export... button.

3. Browsethe destination folder and formats.

4. Click Save button.

M etashape supports panorama export in the following formats:
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* JPEG (*.jpg)

» JPEG 2000 (*.jp2)

e JPEG XL (*.jxl)

e TIFF/GeoTIFF (* tif, *.tiff)
* PNG (*.png)

* BMP (*.bmp)

» GeoPackage (*.gpkg)

e MBTiles (*.mbtiles)

» TileMap Service Tiles (*.zip)
» Google Map Tiles (*.zip)
* Google KMZ (*.kmz)

» World Wind Tiles (*.zip)
3D model export

To export 3D model

1. Select Export Model... command from the File menu.

2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.
3. Inthe Export Model dialog indicate export parameters applicable to the selected file type.

4. Click OK button to start export.

5.  The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

M etashape supports model export in the following formats:
» Wavefront OBJ (*.obj)

» 3DSfileformat (*.3ds)

* VRML models (*.wrl)

« COLLADA (*.dae)

e Stanford PLY (*.ply)

» X3D models (*.x3d)

e STL models (*.stl)
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» Alembic (*.abc)

e Autodesk FBX (*.fbx)

* Autodesk DXF Polyline (*.dxf)

« Autodesk DXF 3DFace (*.dxf)

» Open Scene Graph Binary (*.osgb)
» Open Scene Graph Text (*.osgt)

e Binary gITF (*.glb)

e U3D models (*.u3d)

Adobe PDF (*.pdf)

Some fileformats (OBJ, 3DS, VRML, COLLADA, PLY, FBX) save texture image in aseparatefile. The
texture file should be kept in the same directory as the main file describing the geometry. If the texture
atlas was not built only the model geometry is exported.

M etashape supports direct uploading of the models to Sketchfab resource. To publish your model online
use Upload Data... command from the File menu.

Extra products to export

In addition to main targeted products M etashape allows to export some other processing results, like:

- Convert Images... command is available from Export submenu of the File menu and allowsto export free
of lens distortions and geometrically corrected images. It also allowsto convert large imagesto apyramid-
optimized TIFF format for prompt navigation in the Photo view mode.

In the Parameter s section of the Convert |mages dialog window the user can check the following options:
Transform to initial calibration (this parameter includes: remove distortion, center principal point and
square pixels), Apply color correction. Filename template for converted images should also be specified
in the dialog window.

In the Compression section of the Convert Images dialog window the user can set one of the suggested
TIFF compression parameters: LSW, JPEG, Packbits, Deflate; set JPEG quality and specify if Tiled TIFF,
BigTIFFfileor TIFF overviews should also be saved. The corrections can be applied to all cameras, entire
workspace, selected cameras or even to a current photo.

- Depth map for any image (Export Depth... command available from photo context menu). Y ou can export
diffuse map, depth map and normal map.

- High resolution image of the model as it is shown in the Model view mode. Capture View command
available from the context menu shown on right button click in the Model view.

4 Note

* You need to have mesh model generated in the chunk in order to export diffuse map, depth map
and normal map.
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Apply color correction

Filename template: {filename}. {fileext}

Compression
TIFF compression: LZW

JPEG quality: a9

Write BigTIFF file

Entire warkspace

"Convert Images' dialog

Processing report generation

Metashape supports automatic processing report generation in PDF format, which contains the basic
parameters of the project, processing results and accuracy evaluations.

To generate processing report
1. Select Generate Report... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

M etashape processing report presents the following data:
* Model overview in the desired projection.

» Survey data including coverage area, flying altitude, GSD, general camera(s) info, as well as overlap
statistics.

» Camera calibration results: figures and an illustration for every sensor involved in the project.

 Processing parameters used at every stage of the project.
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4 Note

» Processing report can be exported after alignment step.

Survey Data

Fig. Cameralocations and image overlap - shows the model and position the cameras is shown and the
number of overlapsisdisplayedin color.

Number of images - total number of images uploaded into the project.

Camera stations - number of aligned images.

Flying altitude - average height above ground level.

Tiepoints - total number of valid tie points (equals to the number of pointsin the tie points cloud).
Ground resolution - effective ground resolution averaged over all aligned images.

Projections - total number of projections of valid tie points.

Coverage area - size of the area that has been surveyed.

Reprojection error - root mean sgquare reprojection error averaged over all tie points on all images.

Table. Cameras - table with the parameters: camera model, resolution, focal length, pixel size,
precalibrated.

Reprojection error is the distance between the point on the image where a reconstructed 3D point can be
projected and the original projection of that 3D point detected on the photo and used as a basis for the
3D point reconstruction procedure.

Camera Calibration

For precalibrated cameras interior parameters input by the user are shown on the report page. If acamera
was not precalibrated, interior camera parameters estimated by Metashape are presented.

Fig. Imageresidualsfor camera - displaysthe reprojection errorsfor the tie points detected on the source
images, averaged acrossall theimages of the calibration group and inside the certain "cells" on theimages.

Camera name (focal length) - camera model name and number of images.
Type - cameratype.

Resolution - image dimensions in pixels.

Focal Length - focal length in mm.

Pixel Size - pixel sizein um.

Table. Calibration coefficients and correlation matrix - table with the calibration coefficients and
parameters of the covariance matrix (F, Cx, Cy, B1, B2, K1, K2, K3, K4, P1, P2).

Processing Parameters

Processing report contains processing parametersinformation, which is also available from Chunk context
menu. Along with the values of the parameters used at various processing stages, this page of the report
presents information on processing time.
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M etashape matches images on different scales to improve robustness with blurred or difficult to match
images. The accuracy of tie point projections depends on the scale at which they were located. Metashape
uses information about scale to weight tie point reprojection errors. Key point size is the Sigma of the
Gaussian blur at the pyramid level of scales at which the key point was found.

On the processing parameters page of the report (aswell asin chunk information dial og) two reprojection
errors are provided: the reprojection error in the units of key point scale (this is the quantity that is
minimized during bundle adjustment), and the reprojection error in pixels (for convenience). The Mean

key point size value is averaged Key point size value over al key points. Average tie point multiplicity
value istheratio of the total number of projections to the number of tie points.

Camera track creation and fly through video
rendering

In Metashape you can create an overview video of the model along a certain tragjectory. Cameratrack can
be created automatically (using simple preset options), imported from external file and edited manually.

Editing and creation of a track is carried out through the animation panel. To open the panel select
Animation command from the View menu.

To manually create a track and add a viewpoint, click Append button on the Animation pane. Append
option will add the current viewpoint to the active camera track.

To automatically create Horizontal track

1. Click Create button on the Animation pane toolbar.

2. Choose Horizontal preset parameter in Create Track dialog window and set the Keyframe count.
3. Click OK button.

4. Adjust the position of the viewpoint in the camera track in Model view by dragging the left mouse
button to display it visualy.

To automatically create Vertical track

1. Click Create button on the Animation pane toolbar.

2. Choose Vertical preset parameter in Create Track dialog window and set the Keyframe count.
3. Click OK button.

4. Adjust the position of the viewpoint in the cameratrack in Model view by dragging the left mouse
button to display it visualy.

Horizontal and vertical track presets are basing on the bounding box - the colored side of the box istreated
as XY plane. The center of the bounding box defines the point of focus and the size of the bounding box
defines the rotation radius.

Use Resize Region and 82’ Rotate Region toolbar buttons to adjust the size and orientation of the
bounding box and then create a new horizontal or vertical animation track, once the orientation of the
bounding box fits your needs.
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4 Note

« To display the camera track path, select Show animation command from the Show/Hide items
submenu on the Model menu.

Camera track parameters can be adjusted in the Animation Settings dialog window. The following
parameters can be changed: Camera Track Label, Duration (in seconds), Field of view (deg), Smooth
camera track option, Loop cameratrack option, Rotation angles convention. Click Settings button on the
Animation pane to open Animation Settings dial og.

Torecord thevideo
To record the video according to the created cameratrack to the externa file:
1. Click on Capture button on the Animation pane toolbar.

2. Select the desired export parameters in the Capture Video dialog, such as export video resolution,
compression type and frame rate.

3. Tosavethetrack path to external file click Save button on the Animation pane.
M etashape supports camera track export in the following formats:

» CameraPath

« KML

. CSV
£ Note

« That KML format is only supported for projects georeferenced in geographic/projected systems
convertible to WGS84 system.

Stereoscopic mode

Metashape supports stereoscopic mode. In Metashape hardware stereo is supported only for systems
(graphics cards) that support the technology Quad Buffered Stereo.

Before starting to use stereo mode adjust the Stereoscopic Display modein the General tab of Preferences
diaog available from Tools menu. Metashape supports simply anaglyph display mode (for red/blue
glasses) aswell ashardware stereo mode that assumes polarization glassesand professional grade hardware
(GPU that supports quad-buffer stereo and 3D monitor). The parameters of the 3D controller can be
adjusted on the Navigation tab available in the Preferences dialog window.

For example, when using Stealth3DMouse controller, virtual com port should be installed before thistype
of controller could be selected on the Navigation tab available in the Preferences dialog window. If 3D
controller cannot be configured on the Navigation tab - the steps below should be executed:

» check the USB Serial Comport in the Ports section of Device manager dialog;

* open Port Settingstab of Propertiesdial og window, then click on Advanced tab. In the Advanced Settings
dialog switch the COM port number to COM3;

* restart the computer;
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* in Metashape open Preferences dialog window from Tools menu and in the Navigation tab you should
be able to select COM 3 port then for the Stealth3DMous device.

Working with stereo pairsin Metashapeis performed in Model view pane with Top predefined view set up.

Setting up stereo mode

1. Align photos. More information about photo alignment refer to Aligning photos section.
2. Switch to Model view pane.

3. Seect Top command from Predefined Views submenu of Model menu.

4, Select Sereo mode view command from the View Mode submenu of the Model menu.

Turn on stereo pair overlay by clicking == Show Images toolbar button.

Navigation
1. Navigate through overlaying stereo pair with right mouse button pressed.

2. Tocontrol 3D cursor depth, navigate with the right mouse button and Shift key pressed. When using
the 3D controller, height change is performed with the help of a special whesl.

Stereo pair selection
1. Right button click on the area of interest on the model and select Filter by point command.

2. Inthe Photos pane select both images of a stereo pair, right click on the selection and choose Look
Through command.

3. To avoid switching between stereo pairs while navigating through model, lock current overlaying

stereo pair by clicking D Lock Image toolbar button.

4. Incaseyou need to select another stereo pair, repeat step two.
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Chapter 4. Improving camera alignment
results

Camera calibration

Calibration groups

While carrying out Align Photo procedure Metashape estimates both interior and exterior camera
orientation parameters, including nonlinear radial distortions. For the estimation to be successful it is
crucial to apply the estimation procedure separately to images taken with different cameras. Once images
have been |oaded in the program, M etashape automatically divides them into calibration groups according
to theimage resolution and/or EXIF metadata: cameratype and focal length. When using manual approach
described below it isimportant to follow the described steps for each calibration group individualy.

Calibration groups can be rearranged manually.

To createanew calibration group

1. Select Camera Calibration... command from the Tools menu.

2. Inthe Camera Calibration dialog box, select images to be arranged in a new group.
3. Choose Create Group command from the selected images context menu.

4. A new group will be created and depicted on the left-hand part of the Camera Calibration dial og box.

To move images from one group to another
1. Select Camera Calibration... command from the Tools menu.
2. Choose the source group from the list on the left-hand part of the Camera Calibration dialog box.

3. Select images to be moved and drag them to the target group on the left-hand part of the Camera
Calibration dialog box.

To place each image into a separate group the Split Groups command can be used. The command is
available on the right button click on a calibration group name in the left-hand part of the Camera
Calibration dialog box.

Camera types

M etashape supports two major types of camera: frame camera and fisheye camera. Camera type can be
set in Camera Calibration dialog box available from Tools menu.

Frame camera. If the source data within a calibration group was shot with aframe camera, for successful
estimation of camera orientation parameters the information on approximate focal length (pix) isrequired.
Obviously, to calculate focal length valuein pixel it is enough to know focal length in mm along with the
sensor pixel sizein mm. Normally this data is extracted automatically from the EXIF meta data.
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Frame camerawith Fisheyelens. If extrawide lenseswere used to get the source data, standard M etashape
cameramodel will not allow to estimate camera parameters successfully. Fisheye cameratype setting will
initialize implementation of adifferent cameramodel to fit ultra-wide lens distortions.

4 Note

« When using the Full model for rolling shutter it is recommended to align images with the
Adaptive camera model fitting option.

In case source images lack EXIF data or the EXIF datais insufficient to calculate focal length in pixels,
M etashape will assume that focal length equalsto 50 mm (35 mm film equivalent). However, if theinitial
guess values differ significantly from the actual focal length, it islikely to lead to failure of the alignment
process. So, if images do not contain EXIF meta data, it is preferable to specify focal length (mm) and
sensor pixel size (mm) manually. It can be done in Camera Calibration dialog box available from Tools
menu. Generally, thisdataisindicated in camera specification or can be received from some online source.
To indicate to the program that the camera orientation parameters should be estimated based on the focal
length and pixel sizeinformation, it is necessary to set the Type parameter on the Initial tab to Auto value.

Camera calibration parameters

Photogrammetric calibration of camerasis performed to determine the values of the interior orientation of
the cameras, including the parameters of distortion of the cameralens. The camera calibration parameters
can be set manualy, if they have been acquired as part of the precalibration procedure.
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ILCE-TRM, FE 24mm F1.4 Camera type: Frame
409 images, 9504x6336 pio

" Pixel size {mm): 0.00373788 x 0.00373733
Focal length (mm): 24
Ruolling shutter compensation: Disabled

Initial  Adjusted

Type: Auto

f: 633

k1

ke

Fixed parameters: Mone

Image-variant parameters: MNone

Image «  Resolution  Camera model Focal length

Ll DSCO023.. 9504x6336  ILCE-7TRM4 14
A DSC023... 9504x6336  ILCE-TRMA 14

"Camera Calibration" dialog

To specify the camera calibration parameters

1.

2.

Select Camera Calibration... command from the Tools menu.

Select calibration group, that requires re-estimation of camera orientation parameters, on the |eft-
hand side of the Camera Calibration dialog box.

In the Camera Calibration dialog box, select I nitial tab.
Modify the calibration parameters displayed on the Initial tab.
Set the Type to the Precalibrated value.

Repeat for every calibration group where applicable.
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7. Click OK button to set the caibration.
The following calibration parameters are available;

f
Focal length measured in pixels.

CX, cy
Principal point coordinates, i.e. coordinatesof lensoptical axisinterceptionwith sensor planein pixels.

b1, b2
Affinity and Skew (non-orthogonality) transformation coefficients.

k1, k2, k3, k4
Radial distortion coefficients.

pl, p2
Tangential distortion coefficients.

4 Note

 Alternatively, initia calibration data can be imported from file using Load button on the Initial
tab of the Camera Calibration dialog box. In addition to Agisoft cameracalibration fileformat it
ispossibletoimport datafrom Australis, PhotoModeler, 3DM CalibCam, CalCam, Inpho camera
calibration, USGS camera calibration, Pix4D camera calibration, OpenCV, Photomod and Z/I
Distortion Grid formats.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos
processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera
Calibration dialog box. Thedetailsabout distortion model sused in M etashapearegiveninthe Appendix D,
Camera models section.

If very precise calibration datais available and should be preserved during camera calibration procedure,
click Select... button next to Fixed parameters: item. In Fixed parameters dialog choose calibration
parameters that are to be fixed and click OK button. The initial values for the chosen parameters will not
be changed during Align Photos and Optimize Cameras operations.

In some cases it may be required to estimate a sub-set of parameters individually for each camerain the
calibration group. In this click Select button and choose these parameters in Image-variant parameters
dialog box.

Adjusted camera calibration data can be saved to file using Save button on the Adjusted tab of the Camera
Calibration dialog box.

Analyzing calibration results

M etashape provides a number of toolsto analyze camera calibration results avail able from context menu
of acameragroup in the Camera Calibration dialog.

Distortion
Distortion tab presents estimated camera distortion plot. Total, Radial, Decentering, Corrections
and Residual options are available in the tab. Distortion graph represent the distortion values and
direction according to the adjusted calibration coefficients values. It shows the plot in the discrete
vectors mode for a central point in the corresponding image cell. Residuals presents residuals graph
which alows to evaluate how adequately the camera is described with the applied mathematical
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model. Notethat residual s are averaged per cell of animage and then acrossall theimagesin acamera
group. Scale reference under the plot indicates the scale of the distortions/residuals.

Profile
Profile tab presents increase of the corresponding radial and decentering distortions with distance
from the center of the image. Profiles can be saved asimage.

Correlation
Correlation tab presents:

 Adjusted values of the interior camera orientation parameters;
* Errors- standard deviation;

» Correlation values for interior camera orientation parameters - reflect the degree of correlation
between the corresponding parameters.

Vignetting
Vignetting tab presents radiometric distortion of the lens. Metashape uses radiometric distortion
parameters of the lens from photos meta data, in case there is no information about radiometric
distortion of the lens in photos meta data Vignetting tab is inactive. Radiometric distortion can be
calculated manually using Calibrate Colors command available from the Tools menu, read more in
Building model texture section.

Optimization

Optimization of camera alignment

During photo alignment step Metashape automatically finds tie points and estimates exterior and interior
cameraparameters. However, the accuracy of estimated val ues depends on many factors, including overlap
between the neighboring images, the shape of the object surface, etc. It is recommended to inspect
alignment results in order to delete tie points with excessive values of the reprojection error (if there are
any). Please refer to Editing point cloud section for information on point cloud editing. Once the set of tie
points is edited, it is necessary to run optimization procedure to re-estimate exterior and interior camera
parameters.

During the optimization procedure the exterior and interior camera parameters are cal culated with the use
of thetie points, that areleft after point cloud editing procedure. Providing that outliers have been removed,
the estimated values are more accurate. Also a number of interior camera parameters that were fixed at
the alignment step are estimated, this includes bl (aspect), b2 (skew) and higher order radial distortion
coefficient k4. If re-calculation of the coefficients is not desired, then Adaptive camera model fitting
option can be checked in the Optimize Camera Alignment dialog box. For more information refer to the
Aligning photos section.

To optimize camera alignment

L Choose v Optimize Cameras... command from the Tools menu.

2. InOptimize Camera Alignment dial og box check camera parametersto be optimized. Click OK button
to start optimization.

3. After optimizationiscomplete, estimated interior cameraparameters can beinspected on the Adjusted
tab of the Camera Calibration dialog available from the Tools menu.
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4 Note

« If amodel has been built in the project be fore optimization, it is deleted during the optimization
procedure. The model geometry should be built again when the optimization is completed.
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Using masks

Overview

Masks are used in Metashape to specify the areas on the photos which can otherwise be confusing to
the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of
processing:

» Matching of the images

* Building Depth Maps

* Building Model from the depth maps source with the strict volumetric masks option applied
* Building Texture

 Building Panorama

Alignment of the photos
Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts
of the photos are not taken into account while estimating camera positions. This is important in the
setups, where the object of interest is not static with respect to the scene, like when using aturn table
to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In
this case a small number of useful matches can be filtered out mistakenly as a noise among a much
greater number of matches between background objects.

Building point cloud
While building point cloud, masked areas are not used in the depth maps computation process.
Masking can be used to reduce the resulting point cloud complexity, by eliminating the areas on the
photos that are not of interest.
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Masked areas are always excluded from processing during point cloud and texture generation stages,
including Tiled Model generation process.

Let'stake for instance a set of photos of some object. Along with an object itself on each photo some
background areas are present. These areas may be useful for more precise camera positioning, so
it is better to use them while aligning the photos. However, impact of these areas at the building
point cloud is exactly opposite: the resulting model will contain object of interest and its background.
Background geometry will "consume" some part of mesh polygons that could be otherwise used for
modeling the main object.

Setting the masks for such background areas allows to avoid this problem and increases the precision
and quality of geometry reconstruction.

Building panorama

During panorana generation process, masked areas on the photos are not used for orthorectification
and panorama stitching.

Building texture atlas

During texture atlas generation (for single model and tiled model), masked areas on the photos are
not used for texturing. Masking areas on the photos that are occluded by outliers or obstacles helps
to prevent the "ghosting” effect on the resulting texture atlas.

Loading masks

Masks can beloaded from external sources. M etashape supports|oading masksfrom thefollowing sources:

» From aphachannel of the source photos.

» From separate images.

Toimport masks

1

2.

Select Import Masks... command from the File menu.
In the Import Mask dialog select suitable parameters. Click OK button when done.

When generating masks from separate or background images, the folder selection dialog will appear.
Browse to the folder containing corresponding images and select it.

The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Parameters

Method: From Alpha

Operation: Replacement
Filename template:

Apply to

All images Entire workspace

"Import Masks" dialog
The following parameters can be specified during mask import:

Method
Specifies the source of the mask data.

From Alpha - load masks from alpha channel of the source photos.
From File - load masks from separate images.

Operation
Specifies the action to be done in case a second mask is imported for the photo.

Replacement - new mask will be loaded and stored instead of the original one.

Union - two masks will be united and stored.

I nter section - the intersection of the two masks will be stored as a new mask for the photo.
Difference - only the difference between two masks will be stored as a new mask for the photo.

Filename template (not used in From alpha mode)
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.

{camera} - cameralabel.

{filenum} - sequential number of the mask being imported.

For example, {filename} _mask.png template can be used if masks are available in PNG format and
have a_mask suffix.
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Apply to

Specifies whether masks should be imported for the currently opened photo, active chunk or entire
Workspace.

All camer as - load masks for active chunk.
Entire wor kspace - load masks for all chunks in the project.
Selected camer as - load mask for the currently checked cameras (if any).

Current photo - load mask for the currently opened photo (if any).

Generate masks

The Generate masks tool alows to create masks automatically from the mesh model, from background
images and automatic (Al method).

To generate mask based on reconstructed 3D model

1
2.

Select Generate Masks command from the the Tools menu.

In the Generate Masks dialog select M ethod - From Model and select the necessary parameters to
create amask.

Click OK button when done. The progress dialog box will appear displaying the current processing
status. To cancel processing click Cancel button.

Parameters
Method: From Model
Operation: Replacement

Mask defocus areas

Depth threshold: 1,42

Apply to

All images Entire workspace

Cancel

"Generate Masks' dialog

The following parameters can be specified:

Operation

Specifies how the new masks should be combined with the existing ones if masks already exist in
the project.
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Replacement - new mask will be loaded and stored instead of the original one.

Union - two masks will be united and stored.

I nter section - the intersection of the two masks will be stored as a new mask for the photo.
Difference - only the difference between two masks will be stored as a new mask for the photo.

Mask defocus areas
Enabled applying masksto the areas that are out of focus based on the depth information of each paint.

Blur threshold
Parameter defines the allowed blur radius on a photo in pixels. In most cases, we recommend using
the 2 or 3 pixels.

Depth threshold

The parameter sets the distance from the camera beyond which the image area will be masked.
Available only for the scaled model.

Apply to
Specifies whether masks should be created for:

All images - generate masks for all images in active chunk.
Selected images - generate mask for the currently selected images (if any).
Entire wor kspace - generate masks for all chunks in the project.

Current photo - generate mask for the currently opened photo (if any).

To generate mask from background images
1. Select Generate Masks command from the the Tools menu.

2. Inthe Generate Masks dialog select M ethod - From Background I mage and select the necessary
parameters to create a mask.

3. Click OK button when done. The progress dialog box will appear displaying the current processing
status. To cancel processing click Cancel button.
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Parameters

Method: From Background Image
Operation: Replacement

Filename template:  {filename}_mask.png

Tolerance: u} =

Apply to

All images Entire workspace

Cancel

"Generate Masks' dialog

The following parameters can be specified:

Operation

Specifies how the new masks should be combined with the existing ones if masks already exist in
the project.

Replacement - new mask will be loaded and stored instead of the original one.
Union - two masks will be united and stored.
I nter section - the intersection of the two masks will be stored as a new mask for the image.

Difference - only the difference between two masks will be stored as a new mask for the photo.

Filenametemplate

Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.

{fileext} - extension of the source photo.

{camera} - cameralabel.

Tolerance

Specifies the tolerance threshold used for background differencing. Tolerance value should be set
according to the color separation between foreground and background pixels. For larger separation
higher tolerance values can be used.

Apply to

Specifies whether masks should be created.
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All images - generate masks for all images in active chunk.
Selected images - generate mask for the currently selected images (if any).
Entire wor kspace - generate masks for all chunks in the project.

Current photo - generate mask for the currently opened photo (if any).
To generate mask automatic (Al)

1. Select Generate Masks command from the the Tools menu.

2. Inthe Generate Masks dialog select Method - Automatic (Al) and select the necessary parameters
to create a mask.

3. Click OK button when done. The progress dialog box will appear displaying the current processing
status. To cancel processing click Cancel button.

Al can be used to generate masks for the background. When using the tool for thefirst time, it isimportant
that you have an Internet connection to download the Al model.

Parameters

Method: Automatic (AL)

Operation: Replacement

Apply to
Entire waorkspace
. [=

"Generate Masks' dialog
The following parameters can be specified:
Operation
Specifies how the new masks should be combined with the existing ones if masks already exist in
the project.
Replacement - new mask will be loaded and stored instead of the original one.
Union - two masks will be united and stored.
I nter section - the intersection of the two masks will be stored as a new mask for the photo.

Difference - only the difference between two masks will be stored as a new mask for the photo.

Apply to
All images - generate masks for all images.
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Selected images - generate mask for the currently selected images (if any).
Entire wor kspace - generate masks for all chunks in the project.

Current photo - generate mask for the currently opened photo (if any).

Editing masks

Modification of the current mask is performed by adding or subtracting selections. A selection is created
with one of the supported sel ection tools and is not incorporated in the current mask until it is merged with
amask using Add Selection or Subtract Selection operations.

To edit the mask

1.

Open the photo to be masked by double clicking on its name on the Workspace / Photos pane. The
photo will be opened in the main window. The existing mask will be displayed as a shaded region
on the photo.

Select the desired selection tool and generate a selection.

Selection to subtract the selection from the mask. #. Invert Selection button allows to invert current
selection prior to adding or subtracting it from the mask.

The following tools can be used for creating selections:

Rectangle selection tool

Rectangle selection tool is used to select large areas or to clean up the mask after other selection tools
were applied.

% Intelligent scissors tool

Intelligent scissorsisused to generate a selection by specifying its boundary. The boundary isformed
by selecting a sequence of vertices with a mouse, which are automatically connected with segments.
The segments can be formed either by straight lines, or by curved contours snapped to the object
boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the
selection, the boundary should be closed by clicking on the first boundary vertex.

% ntelligent paint tool

Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image
regions, bounded by object boundaries.

M agic wand tool

Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic
Wand tool, click inside the region to be selected.

The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower
tolerance valuesthe tool selects fewer colors similar to the pixel you click with the Magic Wand tool.
Higher value broadens the range of colors selected.

4 Note

« Toadd new areato the current selection hold the Ctrl key during selection of additional area.
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» To subtract a part from the current selection hold the Shift key during selection of the area to
be subtracted.

» Toreset mask selection on the current photo press Esc key.
A mask can beinverted using Invert Mask command from the Edit menu. The command is activein Photo
view only. Alternatively, you can invert masks either for selected cameras or for al camerasin a chunk

using Invert Masks... command from a photo context menu on the Photos pane.

The masks are generated individually for each image. If some object should be masked out, it should be
masked out on all photos, where that object appears.

Exporting masks

Created masks can be also saved for external editing or storage.

To export masks

1. Select Export Masks... command from the File menu.

2. Inthe Export Mask dialog select suitable parameters. Click OK button when done.
3. Browseto the folder where the masks should be saved and select it.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Parameters

File type: Single channel mask image

Filename template: {filename}_mask.png

Apply to

All images Entire warkspace

"Export Masks" dialog
The following parameters can be specified during mask export:
Export masksfor
Specifies whether masks should be exported for the currently opened photo, active chunk or entire

Workspace.

Current photo - save mask for the currently opened photo (if any).
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Active chunk - save masks for active chunk.
Entire workspace - save masks for all chunksin the project.

Filetype
Specifies the type of generated files.

Single channel mask image - generates single channel black and white mask images.

Image with alpha channel - generates color images from source photos combined with mask data
in apha channel.

Mask file names
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.

{camera} - cameralabel.

{filenum} - sequential number of the mask being exported.

For example, {filename} _mask.png template can be used to export masksin PNG format with _mask
suffix.

4 Note

< When importing/exporting mask for the current photo only, Metashape will prompt for the actual
image instead of image folder. Mask file names parameter will not be used in this case.

Editing point cloud

The following point cloud editing tools are available in Metashape:

» Automatic filtering based on specified criterion (tie points only)

» Automatic filtering based on applied masks (point cloud only)

» Automatic filtering based on points colors (point cloud only)

» Automatic filtering by selection (point cloud only)

» Automatic filtering by confidence (point cloud only)

» Reducing number of pointsin point cloud by setting tie point per photo limit (tie points only)
» Reducing number of point cloud points by setting up point spacing value

» Smooth point cloud

» Colorize pointsin point cloud

* Manual points removal
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Point cloud editing operation can be undone/redone using Undo / Redo command from the Edit menu.

Filtering points based on specified criterion

In some cases it may be useful to find out where the points with high reprojection error are located within
thetie point cloud, or remove points representing high amount of noise. Point cloud filtering helpsto select
such points, which usually are supposed to be removed.

M etashape supports the following criteriafor point cloud filtering:

Reprojection error
Maximum reprojection error is calculated in normalized units for al images where tie point was
measured.

max; [X' - Xi| / s
where

X'j - coordinates of the point projection according to adjusted orientation parameters on the i-th image
in pixels,

Xj - measured point projection coordinates on the i-th image in pixels,

S - the scale of the image that was used for measuring the coordinates of the corresponding projection
on thei-th image.

High reprojection error usually indicates poor localization accuracy of the corresponding point
projections at the point matching step. It is aso typical for false matches. Removing such points can
improve accuracy of the subseguent optimization step.

Reconstruction uncertainty
Ratio of the largest semi-axisto the smallest semi-axis of the error ellipse of the triangulated 3D point
coordinates. The error ellipse corresponds to the uncertainty of the point triangulation alone without
taking into account propagation of uncertainties from interior and exterior orientation parameters.

sart(ky / ks)

where

k, - largest eigenvalue of the tie-point covariance matrix,
k3 - smallest eigenvalue of the tie-point covariance matrix

High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small
baseline. Such points can noticeably deviate from the object surface, introducing noise in the point
cloud. While removal of such points should not affect the accuracy of optimization, it may be useful
to remove them before building geometry in Point Cloud mode or for better visual appearance of the
point cloud.

Image count
Number of images where the tie point was measured.

M etashape reconstruct all the points that are visible at |east on two photos. However, points that are
visible only on two photos are likely to be located with poor accuracy. Image count filtering enables
to remove such unreliable points from the cloud.
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Projection Accuracy

Average image scale that was used for measuring coordinates of the projections of the tie-paint.
sumijs/n
where

5 - the scale of theimage that was used for measuring the coordinates of the corresponding projection
on thei-th image,

n - number of images where tie-point was measured

Thiscriterion alowsto filter out pointswhich projections were relatively poorer localized dueto their
bigger size.

Toremove points based on specified criterion

1

Switch to Point Cloud view mode using 2aTie Points toolbar button.
Select Tools > Tie Points> Clean Tie Points command.
In the Clean Tie Points dialog box specify the criterion to be used for filtering. Adjust the threshold

level using the slider. The selection changes while dragging the slider. Click OK button to finalize
the selection.

To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on applied masks

To remove points based on applied masks

1

Switch to Point Cloud view mode using === Point Cloud toolbar button.
Choose Select Masked Points... command from the Point Cloud submenu of the Tools menu.

In the Select Masked Points dialog box indicate the photos whose masks to be taken into account.
Adjust the edge softness level using the dslider. Click OK button to run the selection procedure.

To remove selected points use Delete Selection command from the Edit menu or click Pt Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on points colors

Toremove points based on points colors

1

Switch to Point Cloud view mode using =52 Point Cloud toolbar button.
Choose Select Points by Color... command from the Point Cloud submenu of the Tools menu.

In the Select Points by Color dialog box the color to be used as the criterion. Adjust the tolerance
level using the slider. Click OK button to run the selection procedure.
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To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points by selection

Filter by selection
Switch to Point Cloud view mode using === Point Cloudtoolbar button.

Select pointsto befilter . - iRectangle Selection, {_“Circle Selection or -;_ﬂ Free-Form Selection tools.
3. Choose Filter By Selection... command from the Point Cloud submenu of the Tools menu.
4. Theresult of thefiltering will be shown in the Model view.

5. Select Reset filter command from the Point Cloud submenu of the Tools menu to cancel filtering
by classes

Filtering points by confidence

M etashape supports point cloud filtering by confidence value. To perform such filtering Calculate point
confidence option should be enabled in the Build Point Cloud dialog before the point cloud of interest
is generated.

Filter by confidence

1 Switch to Point Cloud view mode using =55 Point Cloud Confidence toolbar button.

2. Choose Filter by Confidence... command from the Point Cloud submenu of the Tools menu.

3. Inthe Sdlect Confidence Range dialog box choose min and max value to be used as the filter. The
values define the number of depth mapsinvolved in the point generation.

4. Click OK button to run the selection procedure.
5.  Theresult of the filtering will be shown in the Model view.

6. Select Reset filter command from the Point Cloud submenu of the Tools menu to cancel filtering by
confidence.

Tie point per photo limit

Filter

Tiepoint limit parameter could be adjusted before Align photos procedure. The number indicatesthe upper
limit for matching points for every image. Using zero value doesn't apply any tie-point filtering.

The number of tie points can also be reduced after the alignment process with Tie Points - Thin Point
Cloud command available from Tools menu. Asaresultstie point cloud will be thinned, yet the alignment
will be kept unchanged.

point cloud

In Metashape it is possible to reduce the number of the point cloud points by setting the point spacing
parameter manually which defines the regular grid step.
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Tofilter point point cloud

1. Select Filter point cloud command from the Point Cloud submenu of the Tools menu.

2. IntheFilter Point Cloud dialog box specify Point spacing in metersto be used.

3. Click OK button to run the selection procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4  Note

* In the confirmation dialog box click Yes button if a new point cloud instance with result
calculation should be created in the active chunk. If No button is pressed the point cloud filtering
result will overwrite the active point point cloud instance.

Smooth Point Cloud

M etashape supports the option to smooth point cloud. Thetool allowsto reduce the noise level of the point
cloud. During the smoothing process, the al gorithm consi dersthe neighboring pointsin some neighborhood
for each point of the cloud. The neighborhood is defined by a sphere with the specified radius. For each
point from the neighborhood a plane is considered that is perpendicular to the point's normal, then the
original 3D point is projected onto this plane. The effect of the point from the neighborhood is measured
proportionally to the distance between the projection of the original 3D point and the considered point from
the neighborhood - more distant points have much less effect than close points. When al the points from
the neighborhood are considered, the new position of the original 3D point is determined as the average
position of the projections mentioned above, taken with the weight proportional to the discussed distances.

To smooth point cloud

1. Select an active Point Cloud on the Workspace pane.

2. Choose Smooth Point Cloud... command from the Point Cloud submenu of the Tools menu.

3. Inthe Smooth Point Cloud dialog box set the radius of the ball in in which the approximate position
of the point will be searched. Smoothing radius can be set in meters or in points (the point size is
comparable to the resolution of the point cloud). Smoothing can be applied only in the selected area
of the point cloud.

4. Click OK button to start the procedure. The progress dialog box will appear displaying the current
processing status.

£ Note

» Smoothing can be applied only in the selected area of the point cloud. Select a part of the point
cloud using the selection tools, and then run the tool and enable Apply to selection option.

Colorize Point Cloud

M etashape supports the option to colorize point clouds with the colors from the images.

To colorize point cloud

1.

Select an active Point Cloud in the Workspace pane.
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Choose Colorize Point Cloud... command from the Point Cloud submenu of the Tools menu.
In the Colorize Point Cloud dialog box select Source data from Images option.

Click on the OK button to start the procedure. The progress dialog box will appear displaying the
current processing status.

Manual points removal

Incorrect points can be also removed manually.

Toremove pointsfrom a point cloud manually

1

Switch to Tie Point Cloud view mode using 22 Point Cloud toolbar button or to Point Cloud view

mode using Point Cloud toolbar button.

Select points to be removed using [ Rectangle Selection, _7 Circle Selection or Lj Free-Form
Selection tools. To add new points to the current selection hold the Ctrl key during selection of
additional points. To remove some points from the current selection hold the Shift key during
selection of pointsto be removed.

To delete selected points click the X Delete Selection toolbar button or select Delete Selection

command from the Edit menu. To crop selection to the selected points click the ﬁ Crop Selection
toolbar button or select Crop Selection command from the Edit menu.

Deleting points via Crop Selection or Delete Selection tools simply invalidates them, i.e. the points will
still be stored in the project and they can be restored (all deleted points). If all the deleted points need to
be deleted without the possibility of recovery, then use Compact Point Cloud command from the Point
Cloud submenu of the Tools menu, and then save the project.

Editing model geometry

The following model editing tools are available in M etashape:

Decimation tool

Photoconsistent mesh refinement tool

Close holes tool

Smooth tool

Colorize vertices

Automatic filtering based on specified criterion
Manual polygon removal

Fixing mesh topology

More complex editing can be donein the external 3D editing tools. M etashape allows to export model and
then import it back for this purpose.

68



Editing

4 Note

 For polygon removal operations such as manual removal and connected component filtering it
is possible to undo the last mesh editing operation. There are Undo/Redo commands in the Edit
menu.

« Please note that Undo/Redo commands are not supported for mesh decimation and this operation
cannot be undone.

Decimation tool

Decimation is atool used to decrease the geometric resolution of the model by replacing high resolution
mesh with a lower resolution one, which is still capable of representing the object geometry with high
accuracy. Metashape tendsto produce 3D modelswith excessive geometry resolution, so mesh decimation
isusually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands of polygons. While it is acceptable to work
with such a complex modelsin 3D editor tools, in most conventional tools like Adobe Reader or Google
Earth high complexity of 3D models may noticeably decrease application performance. High complexity
also resultsin longer time required to build texture and to export model in PDF file format.

In some casesit isdesirable to keep as much geometry detailsas possiblelikeit is needed for scientific and
archive purposes. However, if there are no special requirementsit is recommended to decimate the model
down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in
Google Earth and alike tools.

To decimate 3D mode
1. Select Decimate Model... command from the Tools menu.

2. Inthe Decimate Model dialog box specify the target number of polygons, which should remain in the
final model. Click on the OK button to start decimation.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

[ Note

e Textureatlasisdiscarded during decimation process. Y ou will have to rebuild texture atlas after
decimation is complete.

Photoconsistent mesh refinement tool

Metashape allows to refine aready reconstructed mesh with respect to camera photos. This is iterative
process that can further recover details on surface. For example it can recover basrelief or ditch.

Torefinemesh

1. Check the model - it will be refined with respect to camera photos. Y ou can duplicate it with right
click on the model and selecting Duplicate... to refine the copy of model.

2. Select Refine Model... command from the Tools menu.

3. Inthe Refine Moddl... dialog box specify the target quality of refinement, number of iterations and
smoothness. Click on the OK button to start refinement.
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4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Refinement parameters

Quality
Specifies the desired refinement quality. Higher quality settings can be used to obtain more detailed
and accurate geometry, but they require longer time for processing. Interpretation of the quality
parameters here is similar to that of accuracy settings given in Building point cloud section.
Iterations
Number of refinement iterations. In some cases additional iterations are able to recover more details,
but it will lead to proportional slow down.
Smoothness
Smaller smoothness parameter |eadsto better features recovering but also it can increase noise. Bigger

smoothness parameter leads to better noise suppression, but can smooth out features too. Changing
smoothness value can help to balance between noise suppression and features recovering.

Colorize model vertices

In Metashape themesh model vertices can be colorized using images, tie pointsor point cloud pointscolors.

To colorize model vertices

1. Select Colorize Vertices command in Model submenu from the Tools menu.
2. Inthe Colorize Model dialog box select source data for the operation.

3. Click on the OK button to start the procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Close holes tool

Close Holes tool provides possibility to repair your model if the reconstruction procedure resulted in a
mesh with several holes, due to insufficient image overlap for example.

Close holes tool enables to close void areas on the model substituting photogrammetric reconstruction

with extrapolation data. It is possible to control an acceptable level of accuracy indicating the maximum
size of ahole to be covered with extrapolated data.

Toclose holesin a 3D model

1. Select Close Holes... command in Model submenu from the Tools menu.

2. Inthe Close Holes dialog box indicate the maximum size of a hole to be covered with the slider.
3. Click on the OK button to start the procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

70



Editing

4 Note

* Thedlider alowsto set the size of aholein relation to the size of the whole model surface.

Smooth tool

The Smooth tool alows you to make the model smoother and remove irregularities on the surface. Some
tasks require a sleek surface disregarding of details or real object more smooth than mesh in Metashape.
Y ou can apply the tool to the entire mesh or only to the selected area.

£ Note

» To apply smoothing to a specific area, you must first select it and then apply the tool.

To smooth model
1. Select Smooth Model... command in Model submenu of Tools menu.

2. Inthe Smooth Model dialog box set the Strength parameter using slider. Y ou can also enable check
box Apply to selected faces.

3. Click OK when done. To cancel processing click Cancel button.

£ Note

 Fix borders option can be applied to the models with the open edges, it allows to preserve the
position of the mesh vertices along the open edges when using smoothing.

Polygon filtering on specified criterion

In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding
the "main" model or big unwanted polygons. Mesh filtering based on different criteria helps to select
polygons, which usually are supposed to be removed.

M etashape supports the following criteria for face filtering:

Connected component size
This filtering criteria alows to select isolated fragments with a certain number of polygons. The
number of polygonsin all isolated components to be selected is set with a dider and is indicated in
relation to the number of polygons in the whole model. The components are ranged in size, so that
the selection proceeds from the smallest component to the largest one.

Polygon size
This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be
selected is set with adider and isindicated in relation to the size of the whole model. This function
can be useful, for example, in case the geometry was reconstructed with the extrapolation and there
is aneed to remove extra polygons automatically added by Metashape to fill the gaps; these polygons
are often of alarger size than therest.

Vertex confidence
This filtering criteria allows to select polygons using confidence value. This parameters available
only if during build model use Depth map as Source data. The value is displayed as a percentage and
corresponds to the percentage of confidence from the maximum value of al confidence.
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Toremove small isolated model fragments
1. Select Tools> Model > Clean Model command.
2. Inthe Clean Model dialog box select Connected component size criterion.

3. Select the size of isolated components to be removed using the slider. Size of the largest component
is taken for 100%. Y ou can observe how the selection changes while dragging the dlider. Click OK
button to finalize the selection.

4. To remove the selected components use Delete Selection command from the Edit menu or click
X Delete Selection toolbar button (or simply press Del button on the keyboard).

Toremovelarge polygons

1. Select Tools> Model > Clean Model command.

2. Inthe Clean Model dialog box select Polygon size criterion.

3. Select the size of polygons to be removed using the dlider. Size of the largest polygon is taken for
100%. You can observe how the selection changes while dragging the dlider. Click OK button to
finalize the selection.

4. To remove the selected components use Delete Selection command from the Edit menu or click

X Delete Selection toolbar button (or simply press Del button on the keyboard).

Note that Metashape always selects the fragments starting from the smallest ones. If the model contains
only one component the selection will be empty.

Manual face removal

Unnecessary and excessive sections of model geometry can be also removed manually.

Toremove part of the model polygons manually

1 Select rectangle, circle or free-form selection tool using . - Rectangle Selection, {_“Circle Sdlection

or 'l_‘: Free-Form Sdlection toolbar buttons.

2. Make the selection using the mouse. To add new polygons to the current selection hold the Ctrl key
during selection of additional polygons. To remove some polygons from the current selection hold
the Shift key during selection of polygons to be excluded.

To delete selected polygons click the Pt Delete Sdlection toolbar button or use Delete Selection

command from the Edit menu. To crop sel ection to the selected polygonsclick the t{- Crop Selection
toolbar button or use Crop Selection command from the Edit menu.

Togrow or shrink current selection

1. Togrow current selection press PageUp key in the selection mode. To grow selection by even alarger
amount, press PageUp while holding Shift key pressed.

2. Toshrink current selection press PageDown key in the selection mode. To shrink selection by even
alarger amount, press PageDown while holding Shift key pressed.
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Fixing mesh topology
Metashape is capable of basic mesh topology fixing.

To fix mesh topology
1. Select View Model Satistics... command from the Tools menu.

2. In the Model Satistics dialog box you can inspect mesh parameters. If there are any topological
problems, Fix Topology button will be active and can be clicked to solve the problems.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Editing model in the external program

To export model for editing in the external program
1. Select Export Model... command from the File menu.

2. Inthe Save Asdialog box, specify the desired mesh format in the Save as type combo box. Select the
file name to be used for the model and click Save button.

3. Inthe opened dialog box specify additional parameters specific to the selected file format. Click OK
button when done.

Toimport edited model

1. Select Import Model... command from the File menu.

2. Inthe Open dialog box, browse to the file with the edited model and click Open.

[ Note

» Metashape supports loading models in Wavefront OBJ, 3DS, STL, COLLADA, Stanford PLY,
Alembic ABC, Autodesk FBX, Autodesk DXF, OpenCTM and U3D file formats only. Please
make sure to select one of these file formats when exporting model from the external 3D editor.

Seamlines editing

Panorama seamlines editing

Metashape software offers various blending options at panorama generation step for the user to adjust
processing to their data and task. However, in some projects moving objects can cause artefacts which
interferewith visua quality of the panorama. To eliminate mentioned artefacts M etashape offers seamline
editing tool. The functionality allows to choose manually the image or images to texture the indicated
part of the panorama from. Thus, the final panorama can be improved visually according to the user's
expectations.

Automatic seamlines can be turned on for inspection in the Ortho view with pressing the = Show
Seamlines button from the Ortho view toolbar.
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To edit panorama seamlines
1. Draw apolygon on the panorama using Draw Patch instrument to indicate the area to be retextured.
2. Select Assign Images... command from the context menu of the selected polygon.

3. IntheAssignImagesdialog box select theimageto texturethe areainsidethe polygon from. Panorama
preview on the Ortho tab allows to evaluate the results of the selection. Click OK button to finalize
the image selection process.

Click F‘:[ﬂ Update Panorama button from the Ortho view toolbar to apply the changes.

Assign Images dialog allows to activate multiple selection option. If the Allow multiple selection optionis
checked, itispossibleto assign several imagesto texture the areainside the polygon from. However, inthis

casethereisno possibility to preview the resulting panorama. It isnecessary to click '_“JIIH Update Panorama
button from the Ortho view toolbar to apply the changes and see the results. Until the changes are applied,
the area of interest will be marked with a net of blue color to indicate that some edits are waiting for
enforcement. Blending method selected at build panorama step will be implemented at panorama editing

step.

Assign Images dialog, aternatively, allows to exclude selected images from texturing the area of interest.
Check Exclude selected images option to follow this way. Please note that in this case preview illustrates
theimageto be excluded, i.d. the results one should expect after applying the changes are not shown. Click

(¥ Update Panorama button from the Ortho view toolbar to apply the changes.
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Using chunks

When working with typical datasets, automation of general processing workflow allowsto perform routine
operations efficiently. Metashape allows to assign several processing steps to be run one by one without
user intervention thanks to Batch Processing feature. Manual user intervention can be minimized even
further dueto 'multiple chunk project’ concept, each chunk to include onetypical dataset. For aproject with
several chunks of the same nature, common operations available in Batch Processing dialog are applied to
each selected chunk individually, thus allowing to set several data setsfor automatic processing following
predefined workflow pattern.

In addition, multiple chunk project could be useful when it turns out to be hard or even impossible to
generate a 3D model of the whole scene in one go. This could happen, for instance, if the total amount
of photographs is too large to be processed at a time. To overcome this difficulty Metashape offers a
possibility to split the set of photos into several separate chunks within the same project. Alignment of
photos, building point cloud, building model, and forming texture atlas operations can be performed for
each chunk separately and then resulting 3D models can be combined together.

Working with chunks is not more difficult than using Metashape following the general workflow. In fact,
in Metashape always exists at |east one active chunk and all the 3D model processing workflow operations
are applied to this chunk.

To work with severa chunks you need to know how to create chunks and how to combine resulting 3D
models from separate chunks into one model.

Creating a chunk

To create new chunk click on the & Add Chunk toolbar button on the Workspace pane or select Add
Chunk command from the Workspace context menu (available by right-clicking on the root element on
the Workspace pane).

After the chunk is created you may load photos in it, align them, generate point cloud, generate mesh
surface model, build texture atlas, export the models at any stage and so on. The models in the chunks
are not linked with each other.

Thelist of all the chunks created in the current project is displayed in the Workspace pane along with flags
reflecting their status.

The following flags can appear next to the chunk name:

R (Refer enced)
Will appear when two or more chunks are aligned with each other.

To move photos from one chunk to another simply select themin thelist of photos on the Wor kspace pane,
and then drag and drop to the target chunk.

4 Note

» Chunk can contain several instances of the same object (point clouds, 3D model, etc).
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Working with chunks

All operations within the chunk are carried out following the common workflow: loading photographs,
aligning them, generating point cloud, building model, building texture atlas, exporting 3D model and so
on.

Note that all these operations are applied to the active chunk. When anew chunk is created it is activated

automatically. Save project operation savesthe content of all chunks. To save selected chunks as aseparate
project use Save Chunks command from the chunk context menu.

To set another chunk asactive
1. Right-click on the chunk title on the Workspace pane.

2.  Select Set Active command from the context menu.

To remove chunk
1. Right-click on the chunk title on the Workspace pane.
2. Select Remove Chunks command from the context menu.

To rearrange the order of chunksin the Workspace pane ssimply drag and drop the chunks in the pane.

Aligning chunks

After the "partiad" 3D models are built in several chunks they can be merged together. Before merging
chunks they need to be aligned.

To align separate chunks
1. Select Align Chunks command from the Workflow menu.

2. Inthe Align Chunks dialog box select chunks to be aligned, indicate reference chunk with a double-
click. Set desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.
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Aligning chunks parameters

Chunk 1 (1035 cameras, 5,940,318 points) [R]

Chunk 2 (598 cameras, 1,970,252 points) [R]

General

Method: Point based
Fix scale

Image Matching

Acouracy: High

Key point limit: 40,000

Apply masks to:

Generic preselection

"Align Chunks" dialog

Thefollowing parameters control the chunksalignment procedure and can be modified in the Align Chunks
dialog box:

Method
Defines the chunks alignment method. Point based method aligns chunks by matching photos across
all the chunks. Camera based method is used to align chunks based on estimated camera locations.
Corresponding cameras should have the same |abel.

Accuracy (Point based alignment only)
Higher accuracy setting hel psto obtain more accurate chunk alignment results. L ower accuracy setting
can be used to get the rough chunk alignment in the shorter time.

Point limit (Point based alignment only)
The number indicates upper limit of feature points on every image to be taken into account during
Point based chunks alignment.

Fit scale
Option refines the scale of chunks during alignment. By default (if this option is not enabled), the
scale will not change.

77



Automation

Preselect image pairs (Point based alignment only)

The alignment process of many chunks may take a long time. A significant portion of thistime is
spent for matching of detected features across the photos. Image pair preselection option can speed
up this process by selection of a subset of image pairs to be matched.

Apply mask to (Point based alignment only)

If apply mask to key points option is selected, areas previously masked on the photos are excluded
from feature detection procedure. Apply mask to tie points option means that certain tie points are
excluded from alignment procedure. Effectively thisimpliesthat if some areais masked at least on a
single photo, relevant key points on the rest of the photos picturing the same areawill be also ignored
during alignment procedure (atie point is a set of key points which have been matched as projections
of the same 3D point on different images). This can be useful to be able to suppress background in
turntable shooting scenario with only one mask. For additional information on the usage of masks
please refer to the Using masks section.

4 Note

e Chunk alignment can be performed only for chunks containing aligned photos.

Merging chunks

After aignment is complete the separate chunks can be merged into a single chunk.

4 Note

* Werecommend processing all theimagesin asingle chunk to provide better accuracy and quality
of thefinal results than the chunking method (separate processing of the sub-sets of the complete
photos set and merging them).

To merge chunks

1

2.

Select Merge Chunks command from the Workflow menu.

In the Merge Chunks dialog box select chunks to be merged and the desired merging options. Click
OK button when done.

M etashape will merge the separate chunksinto one. The merged chunk will be displayed inthe project
content list on Workspace pane.
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Merge chunks parameters

Chunk 1 (799 cameras, 4,652,023 points)

Chunk 2 (1035 cameras, 5,940,318 points)

Depth maps Models

Parameters

Merge tie points Merge assets

Cancel

"Merge Chunks" dialog

Thefollowing parameters control the chunks merging procedure and can be modified in the Merge Chunks
dialog box:

Masks
Defines if masks from the selected chunks should be merged / copied to the resulting chunk.

Depth maps
Definesif depth maps from the selected chunks should be merged / copied to the resulting chunk.

M odels
Defines if models from the selected chunks should be merged / copied to the resulting chunk.

Point clouds
Definesif point clouds from the selected chunks should be merged / copied to the resulting chunk.

Mergetie points
Defines if the projections of the tie points for corresponding features should be merged. Since tie
points merging operation assumes re-matching of the features from different chunks, the operation
may be time consuming. Thus it is recommended to disable tie points merging, unlessit is required
by the task specifics.

Merge assets
Defines, if the processing results selected in the Assets section should be merged to a single asset
of the same type. Selecting Merge Assets option would merge the active assets of the selected types
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from the selected chunks to a single asset of the same type in the merged chunk. In case the option
is unchecked, all the assets of the selected types from the source chunks will be copied individually
to the merged chunk.

Chunks merging result (i.e. images, point clouds and geometry) will be stored in the new chunk and it may
be treated as an ordinary chunk (e.g. the models can be textured and/or exported).

4 Note

« Merging operations will be applied only to the active assets. Disabled (inactive) assets will not
be transferred to the merged chunk, unless Merge Assets option is unchecked. In the latter case
al the assets (both active and inactive) will be copied asindependent assets to the merged chunk.
All assets of Laser Scansand Tiled Model typewill be copied to the merge chunk independently,
regardless of the Merge Assets option selection.

Batch processing

M etashape allows to perform general workflow operations with multiple chunks automatically. It isuseful
when dealing with alarge number of chunks to be processed.

Batch processing can be applied to all chunks in the Workspace, to active chunk, to unprocessed chunks
only, or to the chunks selected by the user. Each operation chosen in the Batch processing dialog will be
applied to every selected chunk before processing will move on to the next step.

General Workflow Import/Export Miscellaneous
Align Photos Import Cameras Align Chunks
Build Model Import Masks Calibrate Colors
Build Panorama Export Cameras Close Holes
Build Point Cloud Export Model Colorize Model
Build Texture Export Point Cloud Colorize Point Cloud
Export Texture Convert Images
Generate Report Decimate Model
Load Project
Merge Chunks
Optimize Alignment
Refine Model
Reset Region
Save Project
Smooth Model
Smooth Point Cloud

To start batch processing
1. Select Batch Process... command from the Workflow menu.
2. Click Add to add the desired processing stages.

3. Inthe Add Job dialog select the kind of operation to be performed, the list of chunks it should be
applied to, and desired processing parameters. Click OK button when done.
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Automation

Repeat the previous steps to add other processing steps as required.
Arrange jobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.

Click OK button to start processing.

N o o &

The progress dialog box will appear displaying the list and status of batch jobs and current operation
progress. To cancel processing click the Cancel button.

Order  Job Type Applies To

Align Photos All Chunks
Build Model All Chunks
Build Texture All Chunks
Export Model All Chunks

Generate Report  All Chunks

Add...

Save project after each step

"Batch Process’ dialog

When the batch processincludesimport/export features that are applied to multiple chunksit is reasonable
to use the following templatesin the Path field of the import/export jobs:

« {filename} - filename (without extension),

{fileext} - file extension,

e {camera} - cameralabel,

{frame} - frame index,

{chunklabéel} - chunk label,

{imagefolder} - folder containing images of an active chunk,

{projectfolder} - path to the folder containing current project,
» {projectname} - current project filename,

» {projectpath} - absolute path to the current project.

Thelist of tasks for batch processing can be exported to XML structured file using P.l Save button in the

Batch processing dialog and imported in a different project using ' Load button.
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Appendix A. Graphical user interface

Application window

General view

Genera view of application window

Model view

Model view tab is used for displaying 3D data as well as for model and point cloud editing. The view of
the model depends on the current processing stage and is also controlled by mode selection buttons on
the M etashape tool bar.

Model can be shown as a point cloud or as amodel in shaded, solid, wireframe or textured mode. Along
with the model the results of photo alignment can be displayed. These include tie point cloud and camera
positions visualized data.

M etashape supports the following tools for navigation in the 3D view:

Tool K eyboard modifier
Rotation Tool Default

Pan Tool Ctrl key pressed
Zooming Tool Shift key pressed

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the

¥¥' Navigation toolbar button.
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Graphical user interface

4 Note

e Zooming into the model can be aso controlled by the mouse wheel.

Photo view

Photo view tab is used for displaying individual images as well as corresponding depth maps in semi-
transparent representation and masks on them.

In the Photo view tab it is alowed to draw masks on the images. Additionally in Photo view tab it is
possible to display the residuals for the tie points providing that the corresponding camerais aligned.

Photo view isvisible only if any image is opened. To open an image in Photo view mode double-click on
the label of the corresponding camera on the Workspace or Photos pane.

Switching to Photo view mode changes the contents of the Toolbar, presenting related instruments and
hiding irrelevant buttons.

Workspace pane

On the Workspace pane al elements comprising the current project are displayed. These elements can
include:

 List of chunksin the project

* List of images and image groupsin each chunk

» Componentsin each chunk

* Masksin each chunk

 Tiepointsin each chunk

» Depth mapsin each chunk

* 3D modelsin each chunk

* Point cloudsin each chunk

» Panoramasin each chunk

o Cameratracksin each chunk

Buttons located on the Workspace pane toolbar allow to:
» Add chunk

» Add photos

» Enable or disable certain cameras or chunks for processing at further stages.
* Removeitems

Each element in the list is linked with the context menu providing quick access to some common
operations.

83



Graphical user interface

Photos pane

Photos pane displaysthelist of images/ masks/ depth mapsin the active chunk in the form of thumbnails.
Buttons located on the Photos pane toolbar alow to:

» Enable/ disable certain images

* Removeimages

* Rotate selected photos clockwise / counterclockwise (for display purposes only)

» Reset current photo filtering option

 Switch between images/ masks/ depth maps thumbnails

* Increase/ decreaseicons size or display detailed information on photos including EXIF data

Console pane

Console paneis used for:

 Displaying auxiliary information

 Displaying error messages

Buttons located on the Console pane toolbar allow:

» Savelog (inHTML, XHTML or Plain Text format)

e Clear log

Jobs pane

Jobs pane is designed for:

» Monitoring the processing status for active and background projects
 Organizing the background processing queue

 Switching between the projects

Buttons located on the pane toolbar allow:

 Start / pause/ cancel the selected tasks

¢ Clear the processing tasks history

» Change the order of the tasks in the processing queue

4 Note

« You can switch between projects by right-clicking on the project name.

Animation pane




Graphical user interface

Animation pane is designed for:

Creating anew cameratrack from pre-sets(Horizontal, Vertical) with the given number of the keyframes
Loading cameratrack from external file in supported formats (Autodesk FBX, Camera Path)
Exporting camera track

Playing the viewpoint camera movement according to the track

Rendering the frame sequence to the form of the separate images for the keyframes

Rendering the frame sequence to the form of the video file

Appending current viewpoint to the cameratrack

Removing keyframes from the camera track

Changing the selected keyframes positions in current camera track sequence and updating selection
viewpoint

Setting the cameratrack parameters (label, duration, field of view, loop cameratrack)

Buttons located on the pane toolbar allow:

Create new track

Load cameratrack

Save camera track

Start / stop the animation according to the camera track
Capture video file

Append current viewpoint to the active cameratrack
Remove selected keyframes from the active camera track
Move selected keyframes up

Move selected keyframes down

Update selected keyframe to the current viewpoint

Change cameratrack settings

4 Note

« To open any pane select a corresponding command from the View menu.

e Todisplay the track path, select Show animation in Show/Hide items submenu from the Model
menul.

« You can adjust the position of the viewpoint in Model view by dragging the left mouse button
to display it visually.
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Graphical user interface

Menu commands

FileMenu

&

New
Open...

Append...

HSave

Save As...

Export Point Cloud...

Export Model...
Export Panorama...

Generate Report...
Export Cameras...

Export Masks...
Export Texture...

Convert Images...

Import Cameras...

Import Masks...

Import Point Cloud...

Import Model...
Import Texture...

Import Video...
Upload Data...

Exit

Edit Menu

)

Undo

Creates an empty Metashape project.
Opens Metashape project file.

Appends existing Metashape project file to the
current one.

Saves Metashape project file.

Saves Metashape project file with a new name.
Savestie point cloud or point cloud.

Saves 3D model.

Exports generated panorama.

Generates Agisoft Metashape processing report in
PDF and HTML formats.

Exports camera positions, orientation dataand tie
points measurements.

Exports masks.
Exports model texture.

Exports the images corresponding to the original
camera with distortion or color correction applied.

Imports camera positions and orientation data.

Imports masks or creates mask from model or
background.

Imports pointsin aform of the point cloud.
Imports polygonal model.
Imports texture and appliesit to the current model.

Imports video in aform of frame sequence and
saves the extracted frames as images.

Uploads generated products (points, textured
models) to one of the supported web-sites.

Closes the application window.

Undo the last editing operation.
Redo the previously undone editing operation.

Adds current selection to the mask.
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Graphical user interface

Edit Menu

Invert Selection

Grow Selection

Shrink Selection

Reset Selection

X Delete Selection

t{- Crop Selection
Invert Mask

% Reset Mask

I\ Rotate Right

A& Rotate Left

View Menu

#, Zoom In

=L Zoom Out

"2 Reset View
Capture View

Full Screen
= Workspace
@ Animation
Photos
El Console
i Jobs

Toolbar
Workflow Menu

Add Photos...

& Add Folder...

Subtracts current selection from the mask.

Inverts current selection for the photo.

Inverts current selection of faces/ points/ cameras.
Grows current selection of model faces.

Shrinks current selection of model faces.

Reset current selection.

Removes selected faces from the model or selected
points from the point cloud.

Crops selected faces/ points.
Inverts mask for the current photo.
Resets mask for the current photo.
Rotates the photo clockwise.

Rotates the photo counterclockwise.

Increases magnification in the active view mode.
Decreases magnification in the active view mode.

Resets the viewport to display the complete model
or photo.

Saves screenshot of current view of the project
(Model/Photo)

Switches to or from Full Screen mode.
Shows or hides Workspace pane.
Shows or hides Animation pane.
Shows or hides Photos pane.

Shows or hides Console pane.

Shows or hides Jobs pane.

Shows or hides Toolbar.

L oads additional photos to be processed by
Metashape.

L oads additional photos from folders to be
processed by Metashape.
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Graphical user interface

Workflow Menu
Align Photos...
Build Model...
Build Texture...
Build Point Cloud...
Build Panorama...
Align Chunks...
Merge Chunks...

Batch Process...

Model Menu
¥ Navigation

r=1

L-. Rectangle Selection

._+ Circle Selection

'l_g Free-Form Selection

Visible Selection

Matching Graph

o Move Object
FH.': Scale Object
ﬁc" Rotate Object
Reset Transform
ﬁl:‘ﬂ Update Transform
C 3y ove Region
Resize Region
@2* Rotate Region
Rotate Region to View

Rotate Region to Local Frame

Reset Region

Estimates camera positions and tie point cloud.
Generates polygonal mesh mode .

Generates texture map for the model.
Generates point cloud.

Generates panorama.

Aligns multiple chunks.

Merges multiple chunks into the single chunk.

Opens Batch Process dialog box.

Switches to navigation mode.

Rectangle selection tool for the elements of the
Model view.

Circle selection tool for the elements of the Model
view.

Free-form selection tool for the elements of the
Model view.

Tool alowsto limit the selection depth, so that
only the area of the model that isvisiblein the
Model view would be selected.

Tool alows to show matching graph between
camera centers.

Switches to object movement tool.

Switches to object scaling tool.

Switches to object rotation tool.

Resets the transformations applied to the object.
Update the transformations to the object.
Switches to volume movement tool.

Switches to volume resize tool.

Switches to volume rotation tool.

Switches to volume rotation to view tool.
Switches to volume rotation to local frame tool.

Resets the transformations applied to the volume to
default.
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Graphical user interface

Model Menu

42 show Cameras
Show Thumbnails
Confidence View

Show Matching Graph

Matching Graph Settings...

[ Show Labels

L) Show Region

% Show Animation
Show Trackball

i‘;’;' Show Info

D Show Grid

#= Show Aligned Chunks

Show All
Hide All

Perspective/Orthographic
Stereo Mode

Single-Sided Rendering

ao . .
oo Tie Points - Colors

ae Tie Points - Image Count

ES Tie Points - Variance
Point Cloud - Solid
Point Cloud - Colors

Point Cloud - Confidence

& Model - Textured

Displays or hides camera positions estimated
during image alignment.

Displays or hides image thumbnailsin the camera
placeholders.

Displays laser scanning point cloud colored
according to the confidence values.

Displays or hides matching graph.

Change matching graph settings.

Displays or hides item labels.

Displays or hides region selector.

Displays or hides animation track.

Displays or hides the trackball.

Displays or hides the auxiliary on-screen
information.

Displays or hides the grid.

Displays all enabled aligned chunks in project

workspace.
Displays all elements at the same time.

Hides all elements.

Switches visualization view between Perspective
and Orthographic.

Enables or disables stereo view mode according to
the parameters specified in Preferences dialog.

Enables or disables Single-Sided Rendering Mode.
The option allows to neglect on parts of the surface
(Point cloud, Model, Tiled model) where normals
are counter directed to the targeted projection
plane.

Displaystie point cloud reconstructed during photo
alignment.

Displaystie point cloud colored by image count.
Displaystie point cloud colored by variance.
Displays point cloud in the solid mode.

Displays colored point cloud.

Displays point cloud colored according to the
confidence values.

Displays 3D model in the textured mode.
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Graphical user interface

Model Menu

4 Modd - Shaded

4 Model - solid
<l> Model - Wireframe

{»' Model - Confidence

Diffuse Map
Norma Map
Occlusion Map
Displacement Map
Matcap Settings...

Predefined views

Photo Menu

¥I' Navigation
L Rectangle Selection
(_ Circle Selection
'13 Free-Form Selection
" Rectangle Mask
% Intelligent Scissors

% Intelligent Paint
M agic Wand

Open Next Photo

Open Previous Photo

Show Masks
= show Depth Maps

oo A
oo Show Points

Show Point Residuals
Show All

Hide All

Displays 3D modé in the shaded mode with
vertices colored with interpolated colors.

Displays 3D model in the solid mode.
Displays 3D mode in the wireframe mode.

Displays 3D model with vertices colored according
to the confidence values.

Displays diffuse map for the textured mode.
Displays normal map for the textured mode.
Displays occlusion map for the textured mode.
Displays displacement map for the textured mode.
Open dialog to select matcap source.

Switches viewport to one of the predefined views
and configures rotation step angle.

Switches to navigation mode.

Rectangle selection tool.

Circle selection tool.

Free-form selection tool.

Rectangle mask selection tool.

Intelligent Scissors selection tool.

Intelligent Paint selection tool.

Magic Wand selection tool.

Opens next photo from the list in the Photos pane.

Opens previous photo from the list in the Photos
pane.

Turns mask shading on or off.
Displays or hides the depth maps overlay.

Displays or hides tie point projections used for the
camera alignment.

Displays or hides the residuals of each point.
Displays all elements at the sametime.

Hides all elements.
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Graphical user interface

ToolsMenu

Build Tie Points...

Thin Tie Points...

Clean Tie Points...

View Matches...

Filter by Image Count...

Filter by Group Count...

Filter by Duration...
Filter by Selection
Reset Filter

Smooth Point Cloud...
Colorize Point Cloud...

Invert Point Normals...

Select Points by Masks...

Select Points by Color...

Filter by Scan Angle...
Filter by Confidence...
Filter by Selection

Reset Filter

Compact Point Cloud...
Restore Point Cloud...
Update Point Cloud...

Refine Mode...
Decimate Modd!...

Smooth Modd!...

Builds tie point cloud based on the estimated
camera parameters available.

Thinstie point cloud by reducing the number of
projections on the individual photos to the given
limit.

Remove tie points based on specified criterion.

Displays View Matches dialog for visual
representation of the common tie points between
the image pairs.

Filter tie points by projections count.
Filter tie points by group count.
Filter tie points by duration.

Filter tie points by current selection.
Reset tie pointsfilter.

Smooth the point cloud according to the smoothing
radius.

Applies colorsto the point cloud points basing on
source images.

Inverts normals for the selected points of the point
cloud.

Selects points according to the masks of the
selected images.

Selects points according to the color and tolerance.

Filtersthe pointsin the LIiDAR point cloud
according to scan angle.

Filters the pointsin the point cloud according to
the calculated confidence value.

Filters the pointsin the point cloud according to
the selected points.

Resets all applied point cloud filters.

Permanently removes all deleted points from the
point cloud.

Restores all deleted points of the point cloud that
were once marked as removed.

Updates statistics of the point cloud, including
point numbers and assigned classes.

Starts photoconsistent model refinement operation.
Decimates model to the target face count.

Smooths model.
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Graphical user interface

ToolsMenu
Clean Modd!...
Close Holes...

Colorize Vertices...

Resize Texture...
View Model Statistics...
View Texture Mapping...

Filter By Selection

Reset Filter

Calibrate Camera...

Show Chessboard...
85 Camera Calibration...

& Optimize Cameras...

Calibrate Colors...

Set Primary Channel...

& set Brightness...

Reduce Overlap...

"% Preferences...

Help Menu
“ Contents
%57 Online Knowledge Base

Check for Updates...

Activate Product...

@ About Metashape...

Remove faces based on specified criterion.
Closes holes on the model surface.

Applies colors to the model vertices basing on
source images or point cloud.

Starts resize texture operation for model.
Collects and displays model statistics.
Displays model texture mapping.

Filters the faces of the polygona model according
to the selected points.

Resets all applied model filters.
Displays lens calibration dialog.
Displays the calibration board on screen.
Displays camera calibration dialog box.

Starts the optimization of exterior and interior
parameters of the aligned cameras.

Displays the color correction dialog for the
brightness and white balance compensation of the
images.

Displays the primary channel selection dialog.

Adjustsimage brightness and contrast for more
convenient display.

Reduces the number of enabled camerasin the
active project to optimize the coverage in case of
excessive overlap.

Displays preferences dialog box.

Displays help contents.
Browse online knowledge base.

Checks if Metashape update is available for
download.

Displays the activation dialog for activation /
deactivation of the product using the activation
key.

Displays program information, version number and
copyright.
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Graphical user interface

Toolbar buttons

General commands

El New
Open

P‘ Save

3D view commands

“} Undo

™ Redo

¥ Navigation

Ll Rectangle Selection

(22 Circle Selection

2 Free-Form Sdlection
Reset Selection
Visible Selection

% Move Region

Resize Region

22’ Rotate Region
Rotate Region to View
Rotate Region to Local Frame
Reset Region

& Move Object

-i.': Scale Object

@ Rotate Object
Reset Transform

EE Update Transform

X Delete Selection

t{- Crop Selection

3D view settings

£ 7oom In

Creates a new Metashape project file.
Opens a Metashape project file.

Saves a Metashape project file.

Undo the last editing operation.

Redo the previously undone editing operation.
Navigation tool.

Rectangle selection tool.

Circle selection tool.

Free-form selection tool.

Resets current selection.

Select only visible surface.

Volume translation tool.

Volume resize tool.

Volume rotation tool.

Rotate reconstruction volume to view.

Rotate reconstruction volume to loca frame.
Resets region according to the actual point cloud.
Model trandation tool.

Model resize toal.

Model rotation tool.

Resets all transformations applied to the model.
Update transformations parameters for the model.
Removes selected faces / points.

Crops selected faces/ points.

Increases magnification.
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Graphical user interface

3D view settings

=% Zoom Out

*#* Reset View

eo __. .

oo Tie Points - Colors

oo __. .

oo Tie Points - Image Count
ES Tie Points - Variance

Show Matching Graph

Matching Graph Settings...

Point Cloud - Solid
Point Cloud - Colors

Point Cloud - Confidence

_;,'; Model - Textured

4> Mode - Shaded

4> Modd - solid
<[> Model - Wireframe

{,. Model - Confidence

Diffuse Map
Normal Map
Occlusion Map
Displacement Map
Matcap Settings...

85 show Cameras
Show Thumbnails
Show Local Axes

£ Show Aligned Chunks

Photo view commands

“) Undo

Decreases magnification.
Resets model view.

Displaystie point cloud reconstructed during
image alignment.

Displaystie point cloud colored by image count.
Displaystie point cloud colored by variance.
Displays or hides matching graph.

Change matching graph settings.

Displays point cloud in the solid mode.
Displays colored point cloud.

Displays point cloud colored according to the
confidence values.

Displays 3D model in the textured mode.

Displays 3D model in the shaded mode with
vertices colored with interpolated colors.

Displays 3D model in the solid mode.
Displays 3D model in the wireframe mode.

Displays 3D model with vertices colored according
to the confidence values.

Displays diffuse map for the textured mode.
Displays normal map for the textured mode.
Displays occlusion map for the textured mode.
Displays displacement map for the textured mode.
Open dialog to select matcap source.

Displays or hides camera positions, reconstructed
during image alignment.

Displays or hides image thumbnailsin the camera
placeholders.

Displays or hides local camera coordinate system
axes.

Displays or hides enabled aligned chunks.

Undo the last mask editing operation.
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Graphical user interface

Photo view commands

™ Redo

¥ Navigation
L] Rectangle Selection
_J Circle Selection

L_ﬂ Free-Form Selection

Reset Selection
" Rectangle Mask
% Intelligent Scissors
% Intelligent Paint
M agic Wand
Y Magic Wand Settings
Reset Mask Selection

~ Add Selection

Invert Selection

& s Brightness

e .

“l Rotate Right

j{;‘

/I Rotate Left

£ 7oom In

=L Zoom Out

** Reset View
Show Masks

=1 show Depth Maps

oo i
oo Show Points

Show Point Residuals

Redo the previously undone mask editing
operation.

Switches to the navigation mode.
Rectangle selection tool.

Circle selection tool for the el ements of the Model
view.

Free-form selection tool for the elements of the
Model view.

Reset current selection.

Rectangle mask selection tool.

Intelligent scissors tool.

Intelligent paint tool.

Magic wand tool.

Changing the parameters of the magic wand.
Resets current mask selection.

Adds current selection to the mask.
Subtracts current selection from the mask.
Inverts current selection.

Adjustsimage brightness and contrast for more
convenient display.

Rotates the image clockwise.

Rotates the image counterclockwise.

Increases magnification.

Decreases magnification.

Resets the viewport to display the whole image.
Enables or disables the mask shading overlay.

Enables or disables the depth map overlay of the
selected level.
Displays or hides tie point projections.

Displays or hides residuals related to tie point
projections.
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Ortho view commands
- Navigation
P Rectangle Selection
. Circle Selection
,L:f: Free-Form Selection
Reset Selection

" Draw Patch

& st Brightness

5
[§) Update Panorama

‘. Zoom In
=% Zoom Out
*T* Reset View

s
=] Show Seamlines

= Show Shapes

Switches to the navigation mode.
Rectangle selection tool.

Circle selection tool.

Free-form selection tool.

Resets current selection.

Switches to the patch drawing tool.

Adjustsimage brightness and contrast for more
convenient display.

Applies all the manual editsto the panorama.
Increases the magnification of theimage in the
Ortho view.

Decreases the magnification of theimagein the
Ortho view.

Resets the viewport to display the complete
orthomosaic or DEM.

Displays or hides orthomosaic seamlines.

Displays or hides shapes.

Hot keys

For convenient operation in the Metashapeit is possible to use Hot keys. Below isalist of default hot keys
that can be customized in the Preferences dialog. Select the Customize button at the Shortcuts menu item.

General
Create new project Ctrl + N
Save project Ctrl +S
Open project Ctrl +O
Run Script Ctrl +R
Full Screen F11
Model View
Undo (only for Delete, Masking and Close Holes  Ctrl +Z
operations)
Redo (only for Delete, Masking and Close Holes  Ctrl +Y
operations)
Switch between navigation and any other Space

previously selected mode
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Graphical user interface

Zoom In

Zoom Out

Reset view

Switch to stereoview mode

Switch between orthographic and perspective view

modes

Change the angle for perspective view
Predefined Views
Top

Bottom

Right

Left

Front

Back

Rotate View
Rotate Up

Rotate Down
Rotate L eft

Rotate Right

Photo View

Next photo (according to Photos pane order)
Previous photo (according to Photos pane order)
Navigation mode

Selection Tools

Rectangle selection

Intelligent scissors

Intelligent paint

Magic wand

Add selection

Subtract selection

Invert selection

Ctrl ++
Ctrl + -
0
9
5

Ctrl + mouse whese

7
Ctrl +7
3
Ctrl +3
1
Ctrl +1

o AN ®©

Page Up
Page Down
\%

M

L

P

w

Ctrl + Shift + A

Ctrl + Shift+ S
Ctrl + Shift + |
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Images

Input formats

JPEG (*.jpg.* .jpeg)

JPEG 2000 (*.jp2, *.j2k)

JPEG XL (*.jxI)

TIFF (* .tif, * tiff)

PNG (*.png)

BMP (*.bmp)

OpenEXR (*.exr)

TARGA (*.tga)

Portable Bit Map (*.pgm, *.ppm)
Digital Negative (*.dng)
Multi-Picture Object (*.mpo)
Norpix Sequence (*.seq)
AscTec Thermal Images (*.ara)

Camera calibration

Import formats

Agisoft Camera Calibration (*.xml)
Australis Camera Parameters (*.txt)
Australisv.7 Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CaibCam Camera Parameters (*.txt)
CalCam Camera Calibration (*.cal)
Inpho Camera Calibration (*.txt)

USGS Camera Calibration (*.txt)

Pix4D Camera Calibration (*.cam)
OpenCV Camera Calibration (*.xml)
Photomod Camera Calibration (* .x-cam)
Z/| Distortion Grid (*.dat)

Appendix B. Supported formats

Undistort formats
JPEG (*.jpg,* .jpeg)
JPEG 2000 (*.jp2, *.j2k)
JPEG XL (*.jxI)

TIFF (* .tif, * tiff)

PNG (*.png)

BMP (*.bmp)
OpenEXR (*.exr)

Export formats

Agisoft Camera Calibration (*.xml)
Australis Camera Parameters (*.txt)
Australisv.7 Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CaibCam Camera Parameters (*.txt)
CalCam Camera Calibration (*.cal)
Inpho Camera Calibration (*.txt)

USGS Camera Calibration (*.txt)

Pix4D Camera Calibration (*.cam)
OpenCV Camera Calibration (*.xml)
Photomod Camera Calibration (* .x-cam)
Z/| Distortion Grid (*.dat)

STMap (*.tif, *.exr)
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Supported formats

Interior and exterior camera orientation
parameters

Import camera positions
Agisoft XML (*.xml)

Autodesk FBX (*.fbx)

Alembic (*.abc)

Realviz RZML (*.rzml)

Inpho Project File (*.prj)

BINGO (*.dat)

Blocks Exchange (*.xml)
N-View Match (*.nvm)

PATB Camera Orientation (*.ori)
VisionMap Detailed Report (*.txt)
Bundler (*.out)

Tie points

Import tie points
Bundler (*.out)

Import formats
Wavefront OBJ (*.obj)
Stanford PLY (*.ply)
ASPRSLAS (*.las)
LAZ (*.laz)

ASTM E57 (*.e57)

Export camera positions

Agisoft XML (*.xml)

Autodesk FBX (*.fbx)

Alembic (*.abc)

Realviz RZML (*.rzml)

Inpho Project File (*.prj)

BINGO Project (*.dat)

Blocks Exchange (*.xml)

N-View Match (*.nvm)

PATB Project (*.pro)

Boujou (*.txt)

Bundler (*.out)

Maya ASCII (*.ma)

CHAN files (*.chan)

ORIMA (*.txt)

AeroSys Exterior Orientation (*.orn)
Summit Evolution Project (*.smtxml)
Omega Phi Kappa (* .txt)

Colmap (*.txt)

Export tie points

Bundler (*.out)

BINGO (*.dat)

ORIMA (*.txt)

PATB (*.ptb)

Summit Evolution Project (*.smtxml)
Blocks Exchange (*.xml)

Tie point cloud / Point cloud

Export formats
Wavefront OBJ (*.obj)
Stanford PLY (*.ply)
ASPRSLAS (*.las)
LAZ (*.l1az)

ASTM E57 (*.e57)
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Supported formats

Import formats

ASCII PTS (*.pts, *.pts.gz)
Point Cloud Data (* .pcd)
PTX format (*.ptx)

Character Separated Values (*.txt, *.csv, *.xyz,

*.asc)

Mesh model

Import model

Wavefront OBJ (*.obj)

3DS models (*.3ds)
COLLADA (*.dae)

Stanford PLY (*.ply)

Alembic (*.abc)

STL models (*.stl)

OpenCTM models (*.ctm)
U3D models (*.u3d)

Autodesk FBX (*.fbx)
Autodesk DXF (*.dxf)

Binary gITF (*.glb)
OpenSceneGraph Binary (*.osgb)
OpenSceneGraph Text (*.osgt)

Texture maps

Import texture
JPEG (*.jpg. *.jpeg)

Export formats

ASCII PTS (*.pts)

Point Cloud Data (* .pcd)

XYZ Point Cloud (*.txt)

Cloud optimized LAZ (*.copc.laz)

U3D (*.u3d)
Autodesk DXF (*.dxf)
potree (*.zip)

Agisoft OC3 (*.oc3)
Topcon CL3 (*.cl3)
Adobe 3D PDF (*.pdf)

Export model

Wavefront OBJ (*.obj)

3DS models (*.3ds)
COLLADA (*.dae)

Stanford PLY (*.ply)

Alembic (*.abc)

STL models (*.stl)

VRML models (*.wrl)

U3D models (*.u3d)

Autodesk FBX (*.fbx)
Autodesk DXF Polyline (*.dxf)
Binary gITF (*.glb)
OpenSceneGraph Binary (*.osgb)
OpenSceneGraph Text (*.osgt)
Autodesk DXF 3DFace (*.dxf)
X3D models (*.x3d)
LandXML (*.xml)

Adobe PDF (*.pdf)

Export texture
JPEG (*.jpo)
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Supported formats

Import texture

JPEG 2000 (*.jp2, *.j2k)

JPEG XL (*.jxI)

TIFF (*.tif, *.tiff)

PNG (*.png)

BMP (*.bmp)

OpenEXR (*.exr)

TARGA (*.tga)

Portable Bit Map (*.pgm, *.ppm)
Digital Negative (*.dng)
Multi-Picture Object (*.mpo)
Norpix Seguence File (*.seq)
AscTec Thermal Images (*.ara)

Video

Import video
AVI (*.avi)

MPA4 (*.mp4)
Flash video (* .flv)
MOV (*.mov)
WMV (*.wmv)

Export texture
JPEG 2000 (*.jp2)
JPEG XL (*.jxI)
TIFF (*.tif)

PNG (*.png)

BMP (*.bmp)
OpenEXR (*.exr)
TARGA (*.tga)

Export video

AVI (*.avi)

MP4 (*.mp4)
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Appendix C. Metashape Preferences

Metashape settings are available in the Metashape Preferences dialog window. The following settings
are available in the Metashape Preferences dialog window: General, GPU, , Appearance, Navigation,
Advanced. All the parameters that are used to configure the program are described in this appendix.

General tab

General GPL)  Appearance  Mavigation  Advanced

User Interface

Language: English

Default view: Tie Points
Theme: Dark

Shortouts: Customize. ..

Sterenscopic Display
Mode: Anaglyph

Parallax: 1.0

Miscellaneous

C:\WUsersVog. tut

General tab

The following settings are available in the Metashape Preferences (General tab) dialog window:
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Metashape Preferences

User Interface
Language - the GUI language can be selected from the available list: English, Chinese, French,
German, Italian, Japanese, Portuguese, Russian, Spanish.

Default view - the representation of the project can be selected. This parameter indicates how the
project isfirst represented when opened in Metashape. The available options are: Point cloud, Dense
cloud or Moddl.

Theme - the GUI appearance. The available options are Dark, Light and Classic. The theme set by
default in Metashape Standard edition is Dark.

Shortcuts for the menu and GUI commands can be adjusted via Customize... button.

Stereoscopic Display
Mode - allows to select the stereo mode. M etashape supports Anaglyph, Hardware, Vertical Split and
Horizontal Split stereo modes.

Parallax - the value is used for the stereoscopic mode (Anaglyph or Hardware) of Model view. The
value is changed from 0O (the stereo effect will not be observed, because the parallax value will be
0) to 2.

Miscellaneous
Check for updates on program startup - alows to enable the option to receive notifications about
the release of new Metashape version.

Writelog tofile - indicate the path to the Metashape log file. The file contains information about the
processing of the project. Log file can be shared with Agisoft support team in case any problem arises
during the data processing in Metashape.
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Metashape Preferences

GPU tab

General GPU  Appearance Mavigation Advanced

GPU devices:

MVIDIA GeForce RTX 3080 (10239 MB, 68 compute units, 171... CUDA, Vulkan

Mote: GPU acceleration is supported for image matching, depth maps generation, model and
DEM generation based on depth maps, texture blending and model refinement.

Warning: When using dedicated GPUs please turn off integrated GPUs and CPU for optimal
performance.

IIse CPU when performing GPU accelerated processing

GPU tab
The following settings are available in the Metashape Preferences (GPU tab) dialog window:

GPU devices
Thelist of all detected GPU devicesis presented.

Use CPU when performing GPU acceler ated processing
The option to use CPU.
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Metashape Preferences

Appearance tab (Model View)

General GPU  Appearance  Mavigation Advanced

Model View General

Ortho View Background color:

by Wiewr
e Text color;

Model colar: #3080b0
Interpolation: Bilinear
Trackball size: 30%
Camera size: 50 px

Paint size: 2 px
Variance scale: 0.00
Default view: Perspective
Grid

Colar:
Transparency: 87%

Line count:

Cell size:

Plane:

Region

Color: Feegeee

Appearance tab (Model View)

Thefollowing settings are available in the Metashape Preferences (Model View on Appearancetab) dialog
window:

General
Background color - allowsto set the color for background for Model view.

Text color - allowsto set the color for Label in Model view.
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Metashape Preferences

Modél color - allowsto specify the color for 3D model in the solid modein Model view.

I nter polation - allowsto choose the interpol ation method to be used when displaying images (Nearest
neighbor or Bilinear).

Trackball size - allowsto specify the size of the trackball that it will be displayed in the Model view.
Thevalue variesfrom 0% to 100%. When using 100%, the trackball will be displayed at the full height
of the Model view. If set 0% - the trackball doesn't display in the Model view.

Camera size - alows to specify the camera size to display in the Model view.

Point size - allows to set the size of the point for tie point cloud and point cloud to display in the
Model view.

Variance scale - allowsto set the scale value for displaying the variance in the Model view.
Default view - allows to select the view of the model when it is opened: Perspective or Orthographic.

Grid
Color - allows to specify the color for grid in Model view.

Transparency - alows to set the transparency in percent. The transparency value varies from 0%
to 100%. The higher the value, the more transparent the grid will be (0% - not transparent, 100% -
maximum transparency).

Linecount - allowsto set line counts.

Céll size - dllowsto set the cell sizein pixels or meters.

Plane - allows to set the plane for grid (XY, XZ or YZ). The grid will be created in the plane that
selected and will be parallel to the location of the axes in the project.

Region
Color - allowsto set the color for region (bounding box).

Base color - alowsto set base colors for region (bounding box).

Transparency - allows to set the transparency in percent. The transparency value varies from 0% to
100%. The higher the value, the more transparent the region will be (0% - not transparent, 100% -
maximum transparency).

Thickness - allows to set the region thickness in pixels.

Point Cloud Bounding Box
Color - allowsto set the color for point cloud bounding box.

Transparency - allows to set the transparency in percent. The transparency value varies from 0% to
100%. The higher the value, the more transparent the region will be (0% - not transparent, 100% -
maximum transparency).

Thickness - allows to set the point cloud bounding box thickness in pixels.

Block Model Bounding Box
Color - allowsto set the color for block model bounding box.
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Metashape Preferences

Transparency - allows to set the transparency in percent. The transparency value varies from 0% to

100%. The higher the value, the more transparent the region will be (0% - not transparent, 100% -
maximum transparency).

Thickness - allows to set the block model bounding box thicknessin pixels.

Camera Track
Color - allows to specify the color for cameratrack.

Thickness - allows to set the thickness in pixels.
Shapes

Obscured transpar ency - allowsto set the transparency in percent for shapes that are located behind
the model.

Default shape color - allows to set the color that will be displayed when opening or creating alayer
with shapesin Moddl view.
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Metashape Preferences

Appearance tab (Ortho View)

General GPU  Appearance  Mavigation Advanced

Model View General

Ortho View Background color: #454545

by Wiewr
e Text color;

Interpolation: Mearest neighbor
Seamlines
Color:

Thickness:

Appearance tab (Ortho View)

Thefollowing settings are available in the Metashape Preferences (Ortho View on Appearance tab) dialog
window:

General
Background color - allowsto set the color for background for Ortho view.

Text color - allowsto set the color for Label in Ortho view.
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Metashape Preferences

I nter polation - allows to select the interpolation method to be used when displaying images (Nearest
neighbor, Bicubic or Bilinear).

Seamlines
Color - dlowsto set the color for seamlines. Colors can be chosen from Basic colors or set the color
manually.

Thickness - allows to set the thickness in pixels (from 1 pixel to 3 pixels). The parameter changes
the thickness for seamlinesin Ortho view.

Appearance tab (Photo View)

General GPU  Appearance  Mavigation Advanced

Model View General

Orthe View Background color:

by Wi
ST Text colar:

Interpolation: Mearest neighbar
Residuals scale: 10.00

Masks

Fill color:

Border colar:

Transparency':

Cancel Apply
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Metashape Preferences

Appearance tab (Photo View)

Thefollowing settings are available in the Metashape Preferences (Photo View on Appearance tab) dialog
window:

General
Background color - allows to set the color for background for Photo view. It may be useful to set a
contrasting background when creating a mask manually to see the edges of the images.

Text color - allowsto select the color for Label in Photo view.

I nter polation - allows to select the interpolation method to be used when displaying images (Nearest
neighbor, Bicubic or Bilinear).

Residuals scale - allows to set residuals scale for tie pointsin Photo View.

Masks
Fill color - allowsto set the color for masks.

Border color - allows to set the color for the mask border. By default, the white color will be used.
Transparency - alows to set the transparency in percent. The transparency value varies from 0%

to 100%. The higher the value, the more transparent the mask will be (0% - not transparent, 100%
- maximum transparency).
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Metashape Preferences

Navigation tab

General GPU  Appearance  Mavigation Advanced

Contrallers
Enable Stealth Z-Mouse controller
Enable Stealth 5-Mouse controller
Enable Stealth V-Mouse controller
Controller Settings
Contraller;
Sensitivity: Invert

Translation:

Rotation:

Navigation tab
The following settings are available in the Metashape Preferences (Navigation tab) dialog window:

Controllers
Enable HID-compliant controller - allows to enable or disable using HID-compliant controller.

Enable Stealth Z-Mouse controller - allowsto enable or disable using Z-mouse controller.
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Metashape Preferences

Enable Stealth S-M ouse controller - allowsto enable or disable using S-mouse controller. Available
controllers will be displayed in the drop down list.

Enable Stealth V-Mousecontroller - allowsto enableor disableusing V-mouse controller. Available
controllers will be displayed in the drop down list.

Controller Settings
Controller - alows to enable controller from the drop-down list. To update the list of available
controllers, click the Update button next to the drop-down list.

Trandation - allows to set the translation for controller (Sensitivity, Invert axes). The Sensitivity
value varies from 0 to 100. To apply this value to a specific axis, enable the checkbox for the
corresponding axis in the Invert axes section.

Rotation - allows to set the rotation for controller (Sensitivity, Invert axes). The Sensitivity value
variesfrom 0to 100. To apply thisvalue to a specific axis, enable the checkbox for the corresponding
axisin the Invert axes section.

Table (Button and Function)
Inthe Controller Settings section set functionsfor controller buttons: to assign anew function, double-
click on the corresponding line and select preferable function from the drop-down list. If the function
isnot set for the button, the value None will be displayed in the Function section.
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Metashape Preferences

Advanced tab

General GPU  Appearance Mavigation Advanced

Project Files

Store absolute image paths

Export / Import

Load thumbnails from EXIF meta data

Miscellaneous
«f Enable YBO =
Enable mipmap generation

Tweaks. .. Cleanup Projects. .. Reset All Settings

Advanced tab
The following settings are available in the Metashape Preferences (Advanced tab) dialog window:

Project Files
Keep key points - allows to enable option for saving key points into project.

K eep depth maps - allows to enable option for saving depth maps for the project. This option helps
save processing time in cases when the point cloud needsto be re-built (for a part of the project) after
itsinitial generation or when both model and point cloud are based on the same quality depth maps.
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Metashape Preferences

Stor e absolute image paths - allows to enable option for saving absolute image paths. Recommend
enable this parameter if project is not moved to another folder or computer.

Export/Import
Strip file extensions from camera labels - allows to enable option for delete file extensions from
camera labels during load photosinto project.

Load camera calibration from XMP meta data - alows to enable option for automatic loading
camera calibration data from XMP.

Load thumbnailsfrom EXIF meta data - allows to enable option for automatic loading thumbnails
from EXIF meta data.

Miscellaneous
Enable fine-level task subdivision - option allows for internal splitting of some tasks to sub-jobs,
thus reducing the memory consumption during processing of large datasets. The tasks that support
fine-level distribution are: Match Photos, Align Cameras, Build Depth Maps, Build Point Cloud

Enable VBO support - allows to turn on parameter for speed up the navigation in the Model view
for point clouds and high polygonal meshes.

Enable mipmap generation - allows to enable parameter to display the texture using mipmap.

Tweaks... - button for creating tweaks. It is suggested to use this button only if it was recommended
by the Agisoft technical support team.

Cleanup Projects... - button for cleanup projects.

Reset All Settings - button for reset all settings.
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Appendix D. Camera models

A cameramodel specifiesthe transformation from point coordinatesin thelocal camera coordinate system
to the pixel coordinatesin the image frame.

Thelocal camera coordinate system has origin at the camera projection center. The Z axis points towards
the viewing direction, X axis pointsto theright, Y axis points down.

The image coordinate system has origin in the middle of the top-left pixel (with coordinates (0.5, 0.5)).
The X axisin the image coordinate system points to the right, Y axis points down. Image coordinates are
measured in pixels.

Neamera
i
—
ZLeamera
Yeamera
.){r'nmrge
X'ecamera
Y'camera

Yvr'magg

Image and camera coordinate systems

Equations used to project a pointsin the local camera coordinate system to the image plane are provided
below for each supported camera model.

The following definitions are used in the equations:

(X, Y, Z) - point coordinatesin the local camera coordinate system,

(u, v) - projected point coordinates in the image coordinate system (in pixels),
f - focal length (in pixels),

Cx, Cy - principal point offset (in pixels),

K1, Ko, K3, Ky4 - radial distortion coefficients (dimensionless),

Py, P, - tangential distortion coefficients (dimensionless),
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Cameramodels

B4, B> - affinity and non-orthogonality (skew) coefficients (in pixels),

w, h - image width and height (in pixels).

Frame cameras

x=X/1Z

y=Y/Z

r = sgrt(x? + y?)

X' = X(1 + Kqr? + Kor* + Kar® + Kar®) + (P1(r2+2x2) + 2P,xy)
Y' = Y(L+ Kar? + Kor* + Kar® + Kar®) + (P(r%+2y?) + 2Pyxy)
u=w*05+c+xT+xB1+YyB>

v=h*05+c, +yf

Fisheye cameras

Xo=X1Z

Yo=Y /Z

fo = Sqrt(xo” + Yo°)

X =Xo* tan™rg/ 1o

Y=VYo* tan'lrol ro

r = sqrt(x? + y?)

X' = X(1 + Kqr? + Kor®* + Kar® + Kar®) + (P1(r2+2x%) + 2P,xy)
Y' =YL+ Kar? + Kor® + Kar® + Kar®) + (P(r+2y?) + 2Pyxy)
u=w*05+c+xf+xB1+YyB>

v=h*05+c, +yf
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